Audio no longer works on Scrivener for iPad

Hello! Over the past few weeks, when I play an audio file inside of Scrivener on my iPad, I can’t hear it. The counter shows that it’s being played; there’s just no audio. My iPad is not having any other sound-related problems.

I use Scrivener as a primary tool for transcribing recorded interviews, so this is a showstopper for me. Any troubleshooting tips or other information that might help?

This seems to be working fine for me in iOS 14, are you perhaps already upgraded to a newer version, and did the drop in playback coincide with any updates, major or minor?

I’m on iPadOS 15.2. It’s possible an auto-update coincided with the problem, but if so, I didn’t notice it.

At the moment it looks like 15.2 is still in beta, so it might be a rough edge that gets smoothed out before release.

Hmm. I don’t know exactly how you’re trying to do this, but audio import and play for mp3 appears to be working for me (in Research), on latest beta 4 of iPadOS 15.2, which I don’t think has had changes in this area.

What I did have trouble with was both typing (transcription) in document and playing at same time. The audio stopped. There may be a trick like Reference to get two apparent edit windows, etc., but I may be able to suggest a better way, if it would be for you.

That’s to use the split-screen ability of iPadOS 15 (especially easy there) to have Scrivener in one pane, and a file view of the audio in the other, so you can play directly from the file by clicking it to bring the player.

This works very smoothly, as demonstrated in attached screenshot, which was done while writing in Scrivener with the audio playing (and controllable, backups, pausing, etc.) from the player on right.

I’m doing this with the audio in Dropbox. This for me is convenient, and only needs the attention to ‘download’ the file, or mark it as always available, so that it will be truly resident on the iPad (Air 4). You can always turn off the always-available after use, to allow storage to be saved — on the other hand, the presence offline might be useful for work when you are…

Best fortune, and good to know, for self and also a journalist friend I can suggest this to, with or w/o Scrivener, as well.

Clive

1 Like

p.s. to get the split screen easily, iPadOs 15 style

  • be in Scrivener
  • tap the three dots at top
  • choose on which side you will want Scrivener pane, via button
  • Scrivener mostly disappears
  • open the app where you will play the audio: Dropbox, Files, etc.
  • now you see Scrivener, also the app
  • can locate the file if necessary, and play it - controls will then show

When you’re done, you can touch and hold the vertical button on the separator bar, and pull fully to the side to close that app pane. If you do that with the file/player, then Scrivener will be back at full screen.

Thanks! What I normally do is to have my text transcription in main window and the audio in the quick reference one, and use the Scrivener keyboard commands to play the audio and skip around. When I started running into problems, I started doing what you suggest, and while it’s better than nothing, I lose the ability to control the audio with Scrivener keyboard commands.

But: I just discovered that this problem only affects audio played over the iPad speakers. Or at least I am able to hear over my AirPods. So it’s way less of a catastrophic problem than if I just couldn’t play audio at all.

Just a point – that ‘download cloud symbol’ or ‘always available’ setting is only if you are using Dropbox to hold the audio file – and then it’s kind of essential.

Reaon: iPad playing of Dropbox files quite often just hangs if Dropbox doesn’t think the file is present.

This is not how Dropbox is supposed to work, but very often how it does, with all sorts of editors, players, and file types, besides those you think to use with Scrivener…