Author name not correct on compile

I’m trying to compile my project however Scrivener keeps pulling through my macbook username as the author name. I’ve set author name within the general tab of preferences however I cannot seem to get that to come out in compile.

I deleted the contact on my mac that had my macbook username in it, hoping that would force it to be overridden by the manually entered scrivener preferences with no luck.

Anyone know how I fix this?

There are various name placeholder tags (see Help>List of All Placeholders…) but the first place they should all look is on the metadata pane (luggage tag) in the Compile dialog. Have you tried that? Fill in Forename and Surname as well as Author.