Author name not showing in pdf compilations

I noticed that after a PDF compilation and opening that PDF in iBooks or Kindle on Mac, there is no author name showing in the the library views. I filled in the author name in Project/Meta-data settings and inside the compiler. Any idea how to fix this? Where should I fill in the author name so it shows up in the library view inKindle and iBooks?

Does the PDF itself have the author meta-data intact? Check in Acrobat, or even just Preview will show you a little of that information, by hitting Cmd-I while viewing the PDF. You should see fields here correlating the fields in the Meta-Data compile option pane:

[size=80]A mix of data from Project Settings and typed in values. Keywords are displayed in Preview’s second Inspector tab[/size]

Hi, no, that field is empty when I check it in preview.
Screen Shot 2015-04-30 at 08.42.03.png

Hmm, well one thing is that you’re using a beta version of Mac OS X, and since the PDF generator is provided by the Mac, we could be looking at a bug in the system (or maybe Apple has changed how to do things once again). To test against that theory, try setting your PDF type to “Proofing” in the Print Settings compile pane. This will be slower, and the quality may not be to your liking (but if it is fine then it might suffice as a work-around for now), so I’m mainly interested to see if the meta-data works using this engine. This uses the Aspose java conversion engine that is mainly used by Scrivener to work with .doc/x and .odt files—it has nothing to do with OS X and thus should be immune from any beta bugs in the current PDF generator.

Yes, I am running the new OSX Yosemite 10.10.4 4 public beta, but it was actually a friend who discovered that the Author name isn’t showing up in a PDF and he is running the previous OSX (I forgot which one that was…).

I compiled to PDF using the proofing setting as you explained. In the pdf info window and in Kindle reader, there is still no Author name showing.

I can create PDFs in 10.7.5, 10.10.3, and 10.10.4 from Scrivener or ANY program. They all have the author’s name when checking the properties in Finder and Preview. But when I open those PDFs in Kindle, none of them show the author’s name.

I think the problem is with Kindle. A search on DuckDuck or similar shows other people with the same problem. The most common solution appears to be to run the PDFs through Calibre.

Very interesting, the curious thing is that even if you type in no meta-data at all, unless you prohibit Scrivener from reading your main contact card, there should be something in the Title and Author fields. The Meta-Data compile pane will take settings from the Project Meta-Data tab, but those will also in turn take settings from the system and the filename of the .scriv if nothing is provided. So at the very least you should have “My Project Name” and “My Contact Name” in the PDF.

Let’s see if it is a problem with PDF alone, then: this time select RTF as your compile format, there is a meta-data pane for this format as well, but you should find it all set up correctly given your description above. Now open the RTF file in TextEdit and hit Opt-Cmd-P to get properties. Do you have meta-data there?

This time there is an author name:
(/see attachment)
Screen Shot 2015-05-01 at 17.37.35.png

Okay, that doesn’t surprise me too much since that should be an entirely different chunk of code putting meta-data into RTFs (though I might be wrong about that). I mainly wanted to make sure that all settings were correct as a control and that there wasn’t a deeper bug with setting meta-data to documents in general.

Very perplexing, but I should note that there is a workaround you could use for the moment by selecting Print instead of PDF, and then once you get the print dialogue use the “Save as PDF” button and in that file dialogue you will have some meta-data fields. These should be pre-filled according to your project settings, but they may not be given the circumstances. At any rate it should give you a properly tagged PDF.

Have you tried making a quick test project, just using the “Blank” starter? I would just type in a word or two into the “Untitled” document, compile to PDF and set up the Meta-Data pane with some test data first, and then if that works, try with your real name and title. I don’t think it’s a content bug because I just tried your name, with the acute accent, and the title and it worked fine on 10.10.3 at least. But this test will help determine if there is something wrong with your project settings. We could reset them if indeed the blank test works flawlessly.

I did it just now as you described. Opening the Pdf and hitting CMD+i show this:
Screen Shot 2015-05-01 at 20.48.46.png

Here is how the meta data looks like in the document:
meta data.png

Well it wouldn’t have any annotations in it, fresh out of compile, so that “pencil” tab you have in the screenshot would be empty. It’s the dog-eared document tab on the left of that palette that shows PDF meta-data.

Sorry, I didn’t even see these different tabs. I checked my project file on this, but there the author field is still empty. The test file though is now correct:
Screen Shot 2015-05-01 at 21.35.53.png

I found the solution, but I don’t understand what is happening.

When I save the compilation as PDF to my project folder, there is no author name in the info pane in the PDF. When I save the exact same way to the desktop, the author name is filled in.

I tried the same with the test file with the same result. Any idea why this is?

Ah ha! Interesting. When you described what was and wasn’t working, I did a few tests, and it looks like there is indeed a potential bug with the PDF writer in that it does not correctly apply some forms of PDF meta-data when writing the PDF to a secondary drive of any form—even if that “drive” is just a mounted read/write DMG created by Disk Utility. So this would be applicable to potentially anything plugged in, flash drives, full external platter drives and even network drives. I don’t have the hardware to test it, but it may apply to internal secondary drives and even partitions, as well.

So it appears for now the best course is to just compile to the local disk and drag the result elsewhere. I’ve tested compiling local then dragging to the disk after and the author field sticks.

I’m not sure if this is an Apple or Scrivener bug. I did check against TextEdit, printing and then saving as PDF using the title field, again targeting the DMG volume I created, and I got full meta-data. So there may be something we can fix in here.

Great! I am happy that there is a way to get this corrected for now. And of course it would be great if it could be fixed inside Scrivener. btw, the incorrect compilation pdf was written on an external drive. Thanks for the support!

Hi, just a short update:
When I save the pdf to dropbox which is installed as folder in my finder, the meta data is correct in the info window in the PDF, as it is when saving it to the desktop.

Very strange. What about the PDF outline, or internal links between documents? If meta-data isn’t working, then I bet those aren’t either. Here’s how Scrivener generates a PDF file:

  1. It generates the PDF data using Cocoa’s standard printing routines (the same as if you went to print and then chose to save to PDF). Meta-data, outlines and internal links aren’t supported in this.

  2. Scrivener then reads the PDF file that was written to disk in step (1) into the PDFKit API and adds the outline, links and meta-data, then re-saves to disk.

So, my guess is that step (2) is failing in this instance. The solution might be to write to a temporary on-disk location in step (1), only moving it to the final location after step (2) has been done.

Actually, I just tried this, and I couldn’t reproduce the problem - exporting to an external hard disk worked fine for me.

Ioa, how did you test this? I found that there did seem to be a refresh bug in the Finder which led me to think it wasn’t working at first. When I export to an external hard disk, if I select the PDF and use “Get Info” in the Finder, the meta-data isn’t reported in the Finder Info window. However, if I then open the file in Preview and close it again, then bring up “Get Info” in the Finder, all of the meta-data is reported correctly. So I think Finder is caching the meta-data as it appears in the file when it is first written and so not displaying it correctly at first.

I tested using an HFS+ format DMG, compiling straight to it from a tutorial copy, using build 25772. I hadn’t been using Finder, just checking Preview’s info pane, as well as using the command-line to search for the presence of the test meta-data in the file at all. In the PDFs that come up empty, the meta-data strings are completely absent from the PDF data, I don’t think it’s a case of the system lagging—but whatever is happening might not happen on all external drives, too. Just try a default standard 40mb HFS+ DMG and see if that works.

Interestingly, I just tried with the stable MAS version, and there I have no problems writing PDF meta-data to the very same DMG:

[size=80]Compile pane settings and resulting string search on compiled PDFs.[/size]

Update: And yes, I just checked and in the PDF compiled from 25772 to the DMG, there is no ToC, and cross-reference links are non-functional (though painted, if the settings have underscores and text colour enabled).