Author Name on facing page compile paperback

I have compiled my manuscript into PDF for paperback formatting. The project title shows up in the header on the right page but my author name is not showing up on the opposite page. I have checked all the settings and it looks to be set up correctly (see list of settings below). Similarly I previously compiled and published a paperback book with the exact same settings and my author name shows up correctly on the left header of each page. I’m at a loss why it’s not working on this project.

Page Settings
Header and Footer Text
Facing Pages

  • in the middle column is <$author>

Is the author name failing to show up at all, or showing up in the wrong place?

That is not all the settings. Did you fill in author information in Preferences?

I think I figured it out. It looks to be in the metadata when you compile, my name was missing so it wasn’t showing up when I compile to PDF for paperback.

Author information in preferences.

There are two places you can set this information.

One, as DrMajorBob has helpfully pointed out twice now, is under the global Scrivener preferences, under General: Author Information. This will set the default used by all of your projects on that instance of Scrivener.

The second is where you found it under the Compile metadata. As I understand it, this is intended to let you easily override on a per-project (or per-compile basis, if you wish) the general settings – say you’re using a pseudonym on a particular project.

Are you sure the second one sets the value of $author?

The manual implies that it does (not as clearly as I’d like) but also implies @PLRuss would have to leave it out in both locations to get a blank for $author.