Auto-capitalisation/formatting, spelling: couple of tiny suggestions

Please could you change the auto-capitalisation of the letter i so that it is only capitalised if it’s followed by a space; I’m really tired of having to manually correct this everytime I type i.e. and get I.e. in the middle of a sentence.

Also, please change the automatic formatting of curly quotes so that they don’t treat an opening parenthesis as the last letter of a word? When you type ("however,…) Scrivener formats that as a closing quote instead of an opening one (Word has no problem with this, so I’m hoping it can’t be too hard).

And please could you add an option to apply language, including “no proofing”, as a format to individual words, not just to whole projects? I have lots of quotes in French, German, Latin, American English, etc. that crop up in my mostly British English prose and I don’t want to add all these to my dictionary, since most of them I will only ever use once. If I “ignore” them, they’re all flagged again next time I open the document, and if I were to add them to my dictionary, many of them are similar to English words that I actually mis-type (my spelling is better than my typing on the whole), so adding them would actually make the spelling check less useful.

And finally, please could we have a spelling check option to ignore words that are in all caps? I’m really bored with having to add everyone’s initials and every acronym and abbreviation I use to my dictionary.

Thanks for a generally great piece of software, however!

Why wait for Scrivener to change something that you can do yourself in half a minute? The substitution facility is there to be used, and setting I.e. to become i.e. is an easy action to take.

Have you bothered checking that you have smart quotes enabled? Seems to work fine here and not heard anyone else complain.

Yes, I have smart quotes enabled; that’s what causes the problem because Scrivener is trying to turn the typewriter quotes into smart ones, but interprets the opening parenthesis into a closing quote, instead of an opening one.

Thanks for the suggestion about adding I.e. as a correction; I had tried this before without success, because I hadn’t realised that I had to check the “enable additional substitutions” tick box before the substitutions worked. However, I still think it would be simpler if Scrivener didn’t capitalise the letter I except when it is followed by a space.

You can disable capitalising ‘I’ by going to tools-options-corrections.
Personally, I find the feature useful.

Agreed; most of the time it’s very useful, which is why I have it enabled, but it would be even more useful if it only auto-capitalised when the letter is i is preceded AND followed by a space (there aren’t any circumstances I can think of where anyone would type I, meaning me, and put punctation immediately after it).

Ahem. “Is it I? It is I. I said, it is I! It is I: and that settles it!” When writing dialog for a character who sounded stilted in the 19th century, of course.

What about, “I, my brother and a friend went …”

:slight_smile:

What about, “I, my brother and a friend went …”

:slight_smile:

“My friend and I, who are quite keen on this sort of thing, would disagree, and to be fair, I…”

No. Enough.

“But I, I, I want to! And you said I could!”

I? I said that, did I? Never mind, stop it now.

“Aye, aye, Captain.”

OK, fair cop. Completely wrong am I. :unamused: (I never write dialogue, which may be why I missed these obvious points.) Thanks to everyone for their comments and example, but I am still baffled as to why this problem never seems to occur with Ms Word.

Meanwhile, two other minor suggestions have come to mind.

Is there any chance that a future version could correct accidental double capitalisation at the start of sentences? I’m a lousy touch typist, and constantly type this like HOwever,… MEanwhile,… etc., etc. there are far too many of these for me to add them all as manual autocorrections. (But, again, I’ve grown used to Word fixing my bad typing for me.)

Also, I routinely type “hte” for “the”, so I added a correction, but I just noticed that Scrivener now mangles words like “highlighted”, where the letters “hte” appear within the word, turning it into “highligthed”. If possible, please could there be an option to only auto-correct whole words, not sequences of letters within them?

+1 to both of these suggestions. Which I guess comes to +2. :laughing: