Auto Capitalisation

It’s very handy that Scrivener automatically capitalises proper names, especially as I type one-handed, but my protagonist is called Holly, which isn’t recognised as a proper name. I’ve looked through preferences and, under Corrections, there’s a System Text Preferences button, but nothing happens when I click it.

Firstly, is this what I need and secondly, anyone know why it’s not working?

Thanks

You could simply set a substitution from holly to Holly in options/corrections/substitutions.

That’s what I’m trying to do

Mac doesn’t have this ?

and this :
image

No, the mac version is as per my screenshot but nothing happens when I click it.

  1. System Preferences
  2. Keyboard
  3. Text
  4. +
  5. add the replacement you want

Thanks, that worked but would still like to know why I couldn’t click the button in Scrivener.

1 Like

What version of Scrivener, and what version of Mac OS?

I think it likely that macOS is loading System Preferences in the background, behind Scrivener.

When I click the ‘System Text Preferences’ button on my Mac in Scrivener, System Preferences activates and appears in the dock at the bottom of my screen, but the actual pane doesn’t come to the forefront—it stays behind the Scrivener interface. I need to either CMD TAB to it or select it in the dock.

Scrivener 3.2.3 & MacOS 12.3.1

Ah yes. I see what you mean now. When I click the button, the little dot appears under the icon in the dock. For some reason, I was expecting a Scrivener window to appear.

Thanks

If it did, then it wouldn’t be System Preferences.