auto capitalization not turning off

I have unchecked the box in preferences (pref > text editing > ‘capitalize…’) that auto-capitalizes the beginning of sentences, but it does not seem to be working. I need this b/c I am writing dictionary articles that use abbreviations (“the 6th c.”) mid-sentence.

Ideally, I would love a function that allowed me to enter words after which a capital should not appear, but that might be a bigger request. For now, is there some other setting I am missing?

Thanks,
Maria

Make sure that you have turned it off in the right place - in the preferences there is a separate option for capitalisation in script mode and normal prose mode.
All the best,
Keith