Auto-chapter headers WITHOUT titles

I’m sorry if this is a question that’s been answered already, but I’ve searched these forums and have only found partial answers (ie, ones that don’t seem to work for me!).

I have the latest beta release (downloaded today). I’ve imported my novel into the novel template and separated the chapters. I’ve kept it simple; my chapters are simple text documents listed one after another (ie, not inside folders).

My chapters don’t have titles. I just want them to be auto-named CHAPTER ONE, CHAPTER TWO, etc. No matter what I do, when I get it to print the auto-chapter number, then it also prints the title. If I uncheck the title box in the Compile section, then the titles disappear… but so do the chapter numbers. It acts like the auto-chapter numbering is locked together with the title – you can either have both or neither.

I’ve also tried unchecking the box that says “Insert subtitles between text elements” but it doesn’t change a thing.

Am I missing something obvious? Or is something that’s just not working in this release?

Otherwise, the software looks awesome! Thanks! :smiley:

Your first instinct was the correct one. You should have the Title checkbox turned off for all types of items, and then whatever is in the prefix/suffix boxes should print despite the checkbox, allowing you to produce generic titles.

So it must simply not be working correctly in this release. What you could do as a workaround is use the Prefix and Suffix together to wrap the title you want to disappear in some kind of pattern. So for example:

Prefix: CHAPTER <$W>%%(
Suffix: )%%

Which will produce something like “CHAPTER TWO%%(Stuff I don’t want)%%”. Then compile and use your word processor to search for %%(*)%% and replace it with a blank string, where the asterisk is whatever that word processor uses for a wildcard.

Ah, okay, thanks! So I haven’t gone completely mad then. :slight_smile:

For some reason my page breaks seem to have switched off (even though I have them selected under Separators and on the chapter documents themselves). I guess I’ll keep plugging away to find out what’s gone wrong there. It was working fine before. Out of interest, though, is there a magic code like <$W> that inserts page breaks that I can add to Modify > Title Settings if I need to?

And is there an expected date to have all these template format type things fully working? I read September 30th for the next release; not sure how definite or complete that version will be?

Thanks so much for your quick response!

Sorta… it’s in the Separators section where you’d want to set up procedural page breaks like that. Since you just have a list of files, you’ll want to change the default settings so that the text separator is a page break instead of an empty line.

We haven’t set a final release date yet, but you are correct the next beta is due by the end of this month.

Thank you!

(Turns out my page break was working after all but I’d accidentally removed the page padding so that in preview mode it just seemed to continue on the next line.)

When compiling to PDF, there seems to be no right margin (text is all the way over to the right). It’s set to Letter size. But no worries if this is a known bug or if it’s something I’m doing wrong; right now I’m still editing and I can worry about formatting later, after the next release.

Thanks again!

Just to chime in–

  • PDF right margin issue is a known bug and has been fixed for the next release.
  • Templates are being updated now (unlikely they’ll all be ready for the next release but some of them might get in there); the prefix+title issue is a programming bug, though, so that’s not something that can be fixed via a template.
  • However, said prefix+title bug should also be fixed for the next beta, so the above doesn’t really matter.

The “insert subtitles between text elements” option is for compiling meta-data–synopsis, notes, etc.; if you choose to have titles inserted then you’ll get “Synopsis”, “Notes”, “Keywords” and so on added before each of these elements. It doesn’t relate to the main document text, as that’s handled by the “Title” checkbox per document type and level.

Thanks, MM for short. :smiley: Good to know. I’ll continue editing in Scrivener and download the next release when it becomes available.