Auto-complete delay needed

Auto-complete is potentially very handy, especially for heavily accented foreign words that I’d rather not look up every time I need to use them (strange character names, such as Stígand).

However, the feature seems way too trigger-happy. As soon as I type the first letter of a word, it is already pulling up the auto-complete suggestion bubble. Very annoying. I have only a few words in my list. One of them begins with a ‘t’, So every time I type any word that begins with a ‘t’, that suggestion comes into view. It’s very intrusive and makes this feature unusable for me.

A few things might help out a great deal:

• Put in an (optional) delay before a suggestion comes up. Even a half second would make a huge difference.
• Refrain from suggestions until at least two letters of the word have been typed, thus greatly minimizing the times the suggestion bubble comes up unnecessarily.

Love this program. I’d just like to see this feature become more usable.


Adding those options could be of use, but in the meantime, maybe remove all but a couple of the t* entries and use TextExpander (or equivalent) for the rest. Then you can set shortcuts as you please. If “.sti” → “Stígand”, TextExpander won’t react until you type all four characters of the shortcut.

TextExpander includes a collection of pre-made shortcuts for accented words, too … and quite a few others.

One workaround…


And another, that works for words, phrases, sentences, and even multiple paragraphs… … 48791ae294

To clarify, the OP needs to disable “Suggest completions as you type” and use ⌥⎋ to complete. (I changed it to F4 at my machine.)

THANK YOU. This is exactly what I needed. And to be clear, the system autocomplete is essentially the kind of solution I wish the app itself provided. I’m turning off the feature in Scrivener and, for the few times I want to use this, I’ll just go to the Mac System Preferences and add an entry.

As a bonus, those shortcuts carry over to your iPhone and vice versa.