Auto-Complete in Inspector?

I have problems with the auto-Complete List. I have some words (TODO//, RESEARCH// et al.) I included in the Auto-Complete List. Scope is ‘All (Text & Scripts)’. Auto-Complete works fine in the Editor, but not when inserting text in a comment or footnote. I’m so sure this worked some time ago, but cannot find a way to get this working now. Am I wrong? Did this disappear with the last update?

I’m working with 10.5.8 on iMac G5 and iBook G4, with 10.6.8 on a MB Pro. The Scrivener Projects are in my Dropbox-folder. Scrivener 2.3 on all machines.

By the way: Is there a way to export and import the Auto-Complete List to other projects?

(I remember I had this problem once and there was a thread about in the forums, but I couldn’t find it. Sorry, if I miss something obvious :wink: )

Hi Ursula,

Hmm, it seems that this has never worked, as I hadn’t added the custom project auto-complete to comments and footnotes in the inspector. I have just fixed this for the next update.

As for getting an auto-complete list into another project, there is no easy way at the moment, although I have just added drag and drop support so that in future you will be able to drag items between project Auto-Complete List windows.

Thanks for bringing these issues up!

All the best,
Keith

Thank you, Keith!
I’m really confused, that you pretend, this has never worked. Must have been a daydream, I find many TODO//s an and REWRITE//s in Comments in my manuscript, but can’t detect the according well written texts…

Sounds good, another thanks!

Is there a clear distinction for English speaking people between ‘in future’ and ‘next update’. Is ‘next update’ sooner than ‘in future’?
Anyway, I learned, that the next (Beta-)update for us PPC users is weeks behind Intel-future. But I’m glad, Scrivener still supports PPC. I still love my iBook G4 for writing. But wouldn’t mind if someone would gift me an iPad. And a new iMac. :wink:

Thanks for helping me dreaming!

Ursula

If Scrivener is designed for Mac, and Pages supports footnotes, why do we have to open documents in Word or Open Office if we want to see footnotes we’ve created? Would it be not possible to export a document direct to Pages?

Hello RonM,

If you search the forum for “Pages”, you’ll find that the reason for this is well explained - for example in a post by Keith Blount at the foot of the page in this thread: [url]Footnotes not endnotes? - #10 by KB]

H

Hi Ursula,

I claim this because I looked at the code, and comments have never had the necessary code in there to enable Scrivener’s project auto-completions. :slight_smile:

As for “next update”, well, that will necessarily be in the future, so I’m a little confused about the question! The next update will be out in the next couple of weeks.

Ron: Please start a new thread for new questions rather than answering to a thread that has nothing to do with your question. :slight_smile: It is not possible to export directly to Pages since .pages is a private file format and Apple does not make it available to third-party developers. Use .docx or .doc format for exporting to Pages, ensuring you are using Scrivener 2.3 and the Java exporters. If you have any questions about this, though, be sure to start a new thread.

All the best,
Keith

Hi Keith,

I don’t want to confuse you, but should these changes in project auto-completions have been applied to the last update some days ago? Unfortunately this still doesn’t work for me. I deleted Preferences, restarted the App and the Mac, with no result. Maybe my iMac is as confused as me :wink:

Please consider my bad English, if my writing confuses you. I’m full of respect and appreciation everything concerning Scrivener!

Ursula

Hi Ursula,

Yes, these changes have been implemented in 2.3.1. I just checked, and they are definitely working - are you sure you are on 2.3.1?

All the best,
Keith

I believe I’m sure :slight_smile:

Scriv 2.3.1.png

The maybe you can give more information on what you are doing, because these things have definitely been implemented and tested. Please describe exactly what steps you take. Remember you can’t hit Escape on its own in comments to bring up completions as that ends editing, do you need to
Use opt-Escape or cmd-period.

They’re not automatically suggested the way they are in the editor (when “suggestion completions as you type” is enabled), but the words from the auto-complete list should be at the top of the suggestions when using Opt-Esc. Cmd-period doesn’t work in the inspector comments and footnotes, but Opt-Esc calls up the list. (It does work in notes, but I gathered this was especially about auto-complete in comments.)

Jennifer, you saved my day!

I spent the last hour writing a post and make screenshots and read the sections about Auto-Complete in the manual again and again, to recheck if I missed something obvious. And of course I’ve been confused about the shortcuts Keith mentioned: I never use them, because I have set the preferences to ‘suggest completions as you type’. Using a shortcut (cmd-period in my case) shows the Preferences Window.

Thank you for your help and thank you, Keith, for your patience. I think, there are technical reasons, why those auto-complete list don’t work in in comments and footnotes.

Ah, d’oh, I never, ever use that option so it didn’t even occur to me. Yes, currently that option only works in the main editor, as do many other options. It’s not a feature of the standard text system, though, and involves a lot of customisation that is difficult to do in many other controls than the main editor, unfortunately.