Auto-complete in Sceenplay Mode

When reading how autocomplete is supposed to work when writing a screenplay, I noticed that it’s supposed to automatically capture characters for autocomplete, but it doesn’t seem to be doing that. What’s worse, if I manually enter a character’s name into the autocomplete, if I use it on a character line it won’t be automatically capitalized, despite a manually typed name being automatically capitalized. This greatly reduces its usefulness.

Am I missing something or is there a way to correct this, particularly the lack of automatic capitalization?

Scrivener on Windows does not currently automatically add text to the auto-complete list, but you can quickly add selected text in the editor to the list via Edit > Add Selection to Auto-Complete List, which is also available via the context menu or the default shortcut Ctrl+G, Ctrl+A (hold Control, then press G, then A)–you can also change the shortcut via Tools > Options: Keyboard (filter by “Add” and you’ll see it).

The project completions not using the proper capitalisation for the script elements is a bug. Until this is fixed, you can work around it by adding the names directly into the element’s auto-complete list in Format > Scriptwriting > Script Settings…, so that you can give it the correct capitalisation. Element-specific completions will be offered before the project auto-complete ones, so even if you have the name both in the script settings and in the project auto-complete list, the top suggestion should be the correct one for where you’re typing.

Thank you. The bug’s annoying, but the work-around should help a bit for the main characters.