Auto-complete List : characters not working?

I regularly need to use the following text for academic citations “@@author-year” — I’ve added @@author-year to the Auto-Complete List but it doesn’t work. All my other auto-complete terms work fine so I know it’s activated. Is this because I’m using characters ?

Yes, the auto-complete system was designed around the assumption of being used for words rather than arbitrary strings containing any type of text, so some forms of punctuation may not work. You might try Apple’s text replacement tool instead, enabled with the Symbol and text substitution checkbox in the Corrections preference pane, and then set up in System Text Preferences. You could add “@@” in the first column and the rest in the second column.

That will of course impact your entire system, not just Scrivener.

Thanks