Auto-complete stopped working after update to 3.3.4 (Mojave machine)

After automatic update to Scrivener 3.3.4, the auto-complete feature stopped working. I didn’t touch anything in my project. Unfortunately, I am unable to locate a link to download Scrivener 3.3.3. Any suggestion? I suppose the problem is due to the changes related to new versions of OS X, because I am still working under Mojave. For the moment, I have installed the 3.2.3 version available in your site and the feature works again.

Version 3.3.1 is probably the best one to downgrade to in a pinch, as it fixes a lot of issues that would be present in 3.2.3 (we only recommend going back that far if you’re on macOS 10.12.x).

Otherwise, yes, there does seem to be an issue with a perhaps overly-applied fix to auto-completions (basically Apple broke them in macOS 14, so the feature has been largely removed save for scriptwriting mode, but I don’t think that fix is needed beyond that version). I’m taking a look into it to see what might be going on.

Thank you very much for your help. As the previous versions doesn’t include a download link I haven’t visited the 3.3.1 section in the Downloads page. Problem solved.

I hear you, I wish that page was a little more transparent. Normally it’s easier but the last two builds were incremental bug fixes that caused a lot of crashing (to the point that some people were even going to Time Machine to downgrade their entire OS), so it didn’t seem wise to keep them up. Sonoma did a number on page layout this year.

Understood. Thank you very much again.

Problem solved in version 3.3.6. Congratulations!

1 Like

I hope this is not a permanent removal. Auto-completion in narrative mode is something that has been important for me to use a number of times so would hate to see it relegated to scriptwriting mode.

@reepicheep Works just fine in 3.3.6 for me. What exactly are you trying to do?

Nothing at the moment. but auto-complete is something I rely on from time to time. I read @AmberV’s comment as meaning the feature had been removed other than in scriptwriting mode and wanted to make sure that would still be available outside of scripts.

You read AmberV’s comment correctly. That feature was disabled in version 3.3.4 due to repeated crashes.

But, it has been restored in version 3.3.6, which was released earlier today.

The version 3.3.6 release notes provide additional details on that.