I’m struggling with the Auto-complete function. I’ve added my words to the auto complete list but the only way it seems to work is by using the escape key which brings up a list of words I can chose from. The manual seems to indicate that auto-complete should complete a name from the list by typing in the first letter of the characters name…but that just doesn’t happen when I try it. I have to hit escape and pick from a list. Any ideas on how I can get to to Auto complete without picking form that list?

I had a similar problem and was directed by the support team here to Preference > Corrections and then the Auto-Completion section of that pane. In my setup only the In script mode only option was selected. De-selecting that gave me what I wanted.