Auto-completion in screenplay mode.

How am I suppose to use auto-completion to complete words. If I’m typing a slugline and it auto-completes IN to INT., I hit ENTER and it will complete it, but it also goes to the beginning of the next line.

In the screenplay settings, the box for “Go To Next Line” is clear for all scene heading possibilities (except TODs, where it is checked), so it shouldn’t go to the next line, but it does. So, am I doing it wrong?

Use the Tab key rather than Enter to accept the suggestion and have the insertion point remain at the end of the word. I’ve got this on the list to look into making the Enter key function the same.