Auto-completion of script elements: pop-up persists

iOS 12.0, using an iPad Pro 10.5", with Apple Smart Keyboard.

When the auto-complete is invoked in script mode, the popup suggestion appears:

  • using a finger to select causes the popup to disappear, as expected

  • using the tab or return key does not dismss the popup, which is left on the screen and follows the cursor down the page until the auto-complete is retriggered.

AFAICT, this is only a problem with the external keyboard — it works fine with the touch-screen tab key. (I only have the ASK so can’t check with any other models).

I think this may be related to this report on the beta, but there’s no follow up, so I’m reporting it again in case there’s a solution : … 13#p272513


This is a ‘me too’ post - I’ve consistently experienced the exact same thing since upgrading to iOS 12.


Not only does the pop-up persist, but if I go back and touch it later to get rid of it, the whole app shuts down.

I’m using the 2nd-gen 12.9-in iPad Pro with the Apple keyboard for it, and all the software is up to date (including iOS 12.1).

A follow up to my initial report…

The bug is still there with the iOS 12.1, but I’ve found a workaround in case anyone is interested, which is that you can dismiss the annoying persistent popup with cmd-. (Command + full stop). I’ve just discovered that this shortcut acts as the escape key (in some apps at least) and gives you a way to dismiss the popup — it’s the only way I’ve found which can do this.

Hope it helps someone…

That’s a useful trick, the Command + full-stop but it’s come too late for me - I found this bug SO exhausting I’ve (reluctantly) moved over to Slugline for iOS. I do keep checking back periodically to see if L&L even acknowledge the bug, let alone eradicate it but so far…no-go. Maybe they’ll get around to it by the time I’ve retired!!

This bug is killing me. Even if I could just turn off the auto-complete feature I’d be okay with it. I use Scrivener for screenwriting, and when my thoughts are flying, and I don’t look up for a second it’s painful to CMD-. kill it.

Or worse - to accept the correction too late, but then have some weird hanging letter on the next line break that I have to delete. Which messes with the hierarchy of where you are at between character->dialogue->parenthetical.

Love the product so so much. Fingers crossed for the bug squash soon?

I use Scrivener for comic book scriptwriting, and I too come across this bug frequently. Really breaks the flow!

Just to be clear, this bug is not restricted to use of an external keyboard. The same thing occurs if one is typing with the onscreen keyboard. (And, of course, even the cmd-period trick is unavailable with the onscreen keyboard.)

yep. Sitll having that problem as well. Although on my 11inch iPad Pro with iPadOS 13 on it, pushing on the name doesn’t kill the app anymore. Still, it would be great to get this fixed so time.

It looks like this bug has been corrected in the new version (1.2).

That’s great – thanks!