auto correct changing correct word to mispelling

In Scrivener 1.6.1, auto correct keeps changing “not” to “nto” (with a red underline)
MOST annoying :angry:

This isn’t a built-in thing, so I’d check whether you have any additional substitutions enabled that might be affecting the letter order “not” to become “nto”. Do you for instance have a substitution to change the typo “ot” to “to”? If so, try adding a space character before it in the substitutions to prevent the switch in the middle of a word.