I love Scrivener, but the only thing that stops me from using this all the time when novel writing is the auto-correct. I have a character named Ben so I set up auto-correct to change ben to Ben, but it’ll also change benefit to Benefit when it does not need to be capitalized. Same goes with a character named Stan and the word capitalizing issues with “stand”. I have not found an option for it to auto-correct whole words and not partial words. Is there a way around this besides manually capitalizing when needed? I’ll admit it. I’m lazy and use auto-correct any chance possible :smiley:

I think I might be doing something wrong, because if I add “Ben” to the project auto-complete list, and set my options to suggest completions even out of script mode, if I type in “be” I get a “Ben” option which I can activate by hitting return, or I can just keep typing and when I hit “nd” the suggestion goes away and nothing is changed. I do not get “Bend”, I get “bend”. What options are you using, and what procedure do you use while typing?

I have the same settings and it still did that for me. I was playing around with it and found that adding a space behind ben in auto-correct fixes the issue. Maybe a reinstall is in order? I’ve just came to the conclusion that all computers hate me. When I had Scrivener on my mac I never had this issue.

Hmm, are there any other settings, such as spelling auto-correct, that might be getting in the way?

I think the confusion here is between using the Auto-Complete List (in the Project menu), which can provide suggestions for words as you type them, and the Substitutions, which if enabled will do an auto-correction of the typed characters. For the latter, yes, this is a known limitation and something we may be able to improve down the road; for now, adding the space character will get around the issue.

Yes it is for the auto correction and adding the space helps but is a little annoying at times. The auto completion works as well so may need to start using that.

Thank you for your help :slight_smile: