Auto-hide scroller displays incorrectly with texture

(I’m on a roll today! Sorry, Keith.)

The auto-hide scroll bar in full screen doesn’t display properly when you’ve selected a texture for the paper. It does not pick up the override color when that option is checked in preferences, and whether or not the option is checked, the scroller itself and the buttons don’t appear. Also, after you’ve moved your cursor off the scroll bar area, it waits a moment and then just disappears rather than fading out gracefully as it does when there’s just a paper color and no texture.

Regardez:funky scrollbar.png

This is more of a known limitation than a bug. :slight_smile: Basically texture-based colours on OS X don’t support transparency, but that scroll type relies on transparency, so it won’t look right. You should choose one of the other scroller types if you want to use a background texture. I suppose I could try to disable the scroller type if the colour uses a pattern, but this involves messing around with the users’ preferences “behind their backs” as it were.

All the best,

Ah. Thanks. I don’t use a paper texture or a scroll bar in full screen anyway, so it was purely experimental.

At least all my latest “bugs” are easy-fixes. :wink: