Auto-numbering and headings

Hi there,
I am fairly new to Scrivener and have the following problem.
I am writing a non-fiction book with lots of chapters, sections, sub-sections etc. all of which have numbers like 1, 1.1, 1.1.1, 1.1.1.1
I used to do this in word by assigning headings 1-n to each heading.
How would I go about doing this in Scrivener?

  1. From what I understood by reading the tutorial, I should pretty much not add numbers to chapters, sections etc. but should rather make every .n (the smallest part lets say 1.1.1.1) a text file on its own in the binder. And then group them in folders etc. And then let “compile” do the numbering. Is that correct? Or is there any other way I can see the numbering while I am going about writing - like Word does?

  2. Certain files I imported from Word show up in the binder, but also have the title (just as in the binder) show up in the text greyed out. When I change the “title” in the text (which is really just the first line of the text), the title of the file in the binder also changes. What kind of function is that and what would I need it for and how do I get rid of it? Because some files in the binder show this behavior, whereas others have their title in the binder that doesn’t show up in the text. I really drives me nuts and I could find the relevant function in the tutorial. Any help is very much appreciated.

-chris.

Chris,

That is correct, best and most flexible usage of Scrivener is to reserve generic information like this for the compilation stage, leaving the Binder as clean as possible. This does have the side-effect of not seeing the numbering in Scrivener itself while you compose, but you may find that to be of less a problem than you anticipate. At least within your drafting work itself, you can get by with leaving all of the numbering (both for the section titling and any cross-referencing) to the compiler. The main reason you would want to see numbering while writing is cross-referencing, and that can be accomplished by simple Opt-dragging in the section item you wish to refer to, in the spot that needs the ref. This will create a “Scrivener Link” in that spot, named by the section you dragged in. This link is functional for you as well, you can just click on it to view it at any time. When you compile, Scrivener will automatically apply the configured title prefix code to the Scrivener Link location as well. So what was “Read more in Code Red” would become “Read more in 23.8.5 Code Red” when compiling. You can even get more fancy with it by typing in [b]<$p>[/b] and creating a Scrivener Link to the target item as well. This will print the page number of the referenced section in Word.

Okay, to get sectional numbering, the counter code you are looking for is [b]<$hn>[/b]. This is a special counter. Unlike the others it has a static value tied to the position of the item which calls it. The other counters all increment as you use them. It will output the type of numbering you are looking for; so that is what you want in your title prefix settings in the compiler.

That all might be a bit “over the head” at this point in time, and rightly so, but if you want to read up on the Formatting features, §23.8 (pg. 311) of the User Manual PDF (in the Help menu) is where you want to go.

One other nice thing about doing this in the compiler is that you can just get about writing for now, and worry about configuration of this kind of stuff later on, after you are more familiar with the program.

A screenshot might help—that doesn’t immediately conjure any feature in my mind. The only thing that emits actual titles into the editor itself is the [b]View/Editor/Show Titles in Scrivenings[/b] option, which works when you are viewing more than one item at a time in Scrivenings mode. However by default it doesn’t use grey text for this—it does have a grey background by default though—so maybe that is what you mean (though even more perplexing, this view option isn’t even turned on by default either). Editing them in the editor when this feature is turned on will edit the actual title in the Binder.

Another thing this could plausibly be is the “Automatically name untitled text documents upon saving” feature, in the General preference tab. However that shouldn’t be triggering after the fact. As the text of the preference implies, it should only trigger if the document is named “Untitled”. It will use the first line of text to do so though, which is why it came to mind.

Again, a screenshot might help. If you don’t have a server, you can attach images to your forum posts here.

Thank you very much for the long and very informative reply. It’s really awesome to get that much help in the forums. All your remarks were right on.
The problem with the grey titles was indeed the view/editor/show titles in scrivenings-option. It really drove me nuts and so I am awfully glad thatÄs solved or rather I understand now how that works.
So thanks again!
-chris.

You’re welcome!