Autocorrect is insistant - and wrong

I have Spell Check turned on, and AutoCorrect turned off, and that’s working fine for me except for the word ‘hadn’t’.

I type hadn and it gets ‘corrected’ to hand, so every time I end up with hand’t, complete with wiggly warning line. I go back and correct it to hadn’t, and the wiggly line vanishes.

I’ve saved ‘hadn’t’, with and without spaces around it. I’ve saved it in my word list, I’ve saved it in Substitutions. It makes no difference. I tried saving ‘hadn’ in case it was the apostrophe that was giving it the yips. No success.

I don’t know:

  1. Why it doesn’t recognise the standard English word hadn’t.
  2. Why it is autocorrecting this word when autocorrect is turned off - it doesn’t, as far as I can tell, autocorrect anything else.
  3. Why adding the word to Learned Words doesn’t make any difference.

It’s something to do with h-a-d-n because I can type hagnover and it leaves it alone but marks it as misspelled, but hadnover becomes handover despite autocorrect being off. The moment I type the n, before I type another letter or a space, it’s changed.

Any suggestions? I’m writing dialogue and ‘hadn’t’ comes up frequently.

Don’t know if it’s significant but I’m on Windows 7, 64 bit.

I’m still using Scrivwin 1.5.6, so it might not be completely applicable, but “hadn’t” works correctly on my installation. Maybe something went fiddly with updating the program to its current incarnation?

Also using 64-bit Windows 7.

Do you have a different substitution set up that’s changing “hadn” to “hand” or “dn” to “nd”? Or do you have any third-party software installed that deals with substitutions like this (text expanders or a global spell check tool, that sort of thing)?

– I bet it’s a substitution to replace “adn” with “and”. Look for that and then edit it to only take effect when you have a space, i.e. make it replace "adn " with "and ".

MM wins the virtual cake - ‘adn’ to ‘and’ was it.

Now it changes ‘a nd’ to ‘a nD’… but I’m just ignoring that because it has a think about it afterwards and changes it again :unamused:

Thanks, all!

Try changing the autocorrect to replace:

"adn " with "and "

That is, add a space after the adn. This should tell the autocorrect to do what you want.

How is this happening with auto-correct turned OFF? Just curious, because auto-INcorrect is what I experienced when I had it turned on once. I spent more time back-spacing to replace words the computer thought I meant to type, or discovering the wrong word later upon a re-read that I wonder how anyone can use the damned feature. You kids these days! shakes fist

It’s not the autocorrect doing it, it’s the additional substitutions.