Autocorrect not working?

Working on a comic script using the template. As far as I can tell, autocorrect is on - but nothing is happening. Is there project specific settings or something? I can’t seem to figure it out.

Some settings to check…

System Preferences > Keyboard > Text > Correct spelling automatically (& Capitalise words automatically, if needed)

And Scrivener > Preferences > Corrections > Correct spelling errors as you type

And, for each project, Edit > Spelling and Grammar > Check Spelling While Typing


I’m afraid I have the same problem. Suddenly autocorrect stopped working in Scrivener 3.1.1, and I can’t get it to re-start, no matter how many times I toggle the various preference checkboxes (in preferences and edit). My Mac (OSX 13.6) seems to still run autocorrect (in notepad, for example), but just in case I’ve toggled these settings as well. Any suggestions?
Many thanks in advance.

I had this problem, too.

Checking Edit > Spelling and Grammar > Check Spelling While Typing fixed it for me. I must have accidentally hit the keyboard shortcut for it at some point. Real mysterious, because I didn’t know this was a thing you could toggle on/off.

1 Like