Automatic Hashtags In Compiled PDF

I searched for this topic before posting and couldn’t find anything, so apologies in advance if this has been asked and answered on the forum.

My chapters and scenes are all separate files in my binder. When I compile a PDF, Scrivener helpfully adds hashtags at the end of scenes to designate scene breaks. It’s a great feature. Except they don’t always show up.

There’s no rhyme or reason to it that I can see. As far as I can tell there’s no difference in formatting or placement between the scenes that do get scene break hashtags at the end and those that don’t. I’m guessing I must be missing something, but what?

The main thing I can think of is that separators only get inserted between other binder items that are using same section layout in compile settings. So conditions that do not match that criteria will not trigger the behaviour (otherwise you would get them in between the chapter heading and the first scene, or at the very end of the chapter, and other undesirable placements).

You can check for scenarios such as these most easily in the Contents tab, on the right-side of the compiler. Pay particular attention to any sections that are using black text instead of italic grey. That indicates you’ve manually overridden the kind of item it is so that it is forced to work a certain way (like a single file being forced to work as a chapter because it was a short one).

If you didn’t mean to do that, you can change the assignment back to “Structure Based” right here in the list. If you’ve got lots of them, and don’t want any of them, you may want to return to the main project window where you can bulk select the entire draft, right-click, and set the Section Type universally back to “Structure Based”.

Another good way of auditing your settings is to scroll through the preview column in the middle and click on the section used for scenes. That will highlight the Contents list for usage, and you can more easily see “gaps”.

I don’t really know what the Contents tab is but it looks like somehow I inadvertently marked several scenes incorrectly as sections. I think that’s what you were suggesting, but either way I’ve changed them and it seems to have worked. Thank you!

This is the Contents tab in Compile. As you can see, it’s a good place to view and adjust section types.

You can find documentation on the Contents Tab in the user manual PDF, §23.4.1, Contents Tab. It’s very useful for double-checking your setup before compiling.

Glad you found the source of the problem.