Automatic indenting

Okay, I have another problem. How do I make it stop indenting each paragraph automatically? I don’t want anything to be automatic. I can type “tab” myself when I want an indent.

(edited to remove a problem I fixed on my own)


In Preferences: Text Editing, set the Indent in that sample paragraph to flush left, but leave the Tab where it is. Then you will have to use Tab to create an indent. When you export, you may have to re-set the Tab position in the word processor of your choice.

Thank you!

I just happened upon this topic. I have the opposite problem: my Scrivener came set with non-automatic indents, and I would prefer automatic. I’ve fiddled with Preferences>Text Editing to no avail.

Thanks for any help you can give.

In Preferences > Text Editing, it’s not the default tab icons on the ruler that set the first line’s indent for a paragraph. Rather, it’s the horizontal line just above this area - it’s a black horizontal bar with a perpendicular thin line hanging down across the ruler. If you drag that about you change the default first-line indent for your paragraphs.
PreviewScreenSnapz001.pdf (16 KB)

Also, bear in mind that Preferences > Text Editing set the defaults for new documents. It has no effect on existing documents, as that would mean wiping out all the different possible styles within each document and replacing them with a single style. If you really want the settings in your Preferences to affect existing documents, you can select the documents in the binder and use Documents > Convert > Formatting to Default Text Style.

All the best,

Thank you both so much for your quick help. I am very impressed by Scr and enjoying spending time with it.javascript:emoticon(’:D’)

I imported text into Scrivener with tabs in place for each new paragraph. Scrivener preferences were set to indent the paragraphs. So now I have lots and lots of paragraphs in dozens of chapters of my novel with both tabs and indents. Is there a way to remove tabs (such as a search/replace function) throughout a chapter without hunting and pecking them one by one?

The normal way would be to set Find and Replace to replace by and then do a “Replace All”. That said, I’ve never done it in Scrivener, preferring to leave such things until I’m formatting in Nisus where I can use their terrific PowerFind Pro to do it easily, so I’m not quite sure how you’d insert a , or perhaps a in the standard dialog in Scrivener … you’d probably need to copy and paste, I should think.


Yeah, I have done things like this by copying and pasting a tab into the forms.


You can also just hold the Option/Alt key down to enter a tab into the find field.

Good to know Keith. Will it work with alt-return though? The thing is if the tab you want to get rid of is at the beginning of a line, replacing return+tab with just return makes sure you don’t lose any tabs that you want to keep, like after a bullet point or a list number.


Yes. Hold Opt/Alt down for any control characters - tab, return etc. This is the same in all Cocoa controls.

I’ve looked and looked and can not seem to see how to get Scrivener to stop indenting text wrap. I do not know why it started doing this seemingly out of the blue. ‘Script Mode - Screenplay’ is not checked, btw.

Any ideas?

Thank you.

MacOS 10.5.1 (Intel)

That’s a ruler setting. Hit cmd-R and change the line indents (the downward-pointing triangle on the left controls line indents after the first). Do the same in Preferences > Text Editing if necessary. You must have changed it by mistake, or pasted in some text formatted like that.

Thank you Keith. Problem solved. As usual, I am my own worst gremlin. :slight_smile: