"Automatically name untitled documents upon saving"

The “Automatically name untitled documents upon saving” feature has stopped working. I have been writing for a few hours and the feature no longer works. I closed and reopened Scrivener. The problem remains. When I hit Ctrl +S, the name of the document remains Untitled.

I am using Version: 1.7.3.0 - 20 Aug 2014.

Please advise. Thank you.

Liz

I think I may have solved the problem. I have another document that begins with the same word as the one I am trying to automatically save. Would this cause Scrivener to not automatically save the second untitled document?

For example, the first document is called “Amber was more than a dog.” The second document begins with the phrase, “Amber died on a Tuesday.”

Liz

There seems to be a confusion here. The option you’re referring to is not associated with Ctrl-S, since Scrivener is always saving your work as you write.

The automatic naming of documents occurs as you type something on the first line of the document. Can you try that, to see if it helps?

Thanks for the reply.

To clarify, since the “Automatically name untitled documents upon saving” function names documents upon saving, and Ctrl + S saves documents, wouldn’t the documents be named after saving with Ctrl + S? Most of the time, this is indeed what happens. The document is automatically named whatever is the first line when I hit Ctrl + S. About 10% of the time, however, this does not happen.

And no, an unnamed document is not automatically named as I type something on the first line of the document.

Am I missing something?

Thank you for the help! I really like this feature and want it to work all the time.

Liz

Hi Liz - Yes, with that setting checked, untitled documents should be renamed with the initial text of the document whenever the program saves, whether it’s an auto-save or you manually typing Ctrl+S (both perform the same action). There are three instances I’m aware of where this won’t happen:

  1. If you’ve deliberately titled the document “Untitled”–that is, it’s not just that you never entered text there, but that you typed in “Untitled” as the name of the document. Strictly speaking this is a bug, but it’s easy to fix by just deleting the text in the title field and then editing the document so it saves again and replaces the title .

  2. If there are fewer than 50 characters in the document. This is also a bug–50 characters is the cut-off when taking text from the document to use as the title, but it shouldn’t be necessary for triggering the auto-titling. I’d be surprised though if this is what you’re running into most of the time, since as soon as you get past 50 characters and the document saves, the auto-titling will kick in.

  3. If the untitled document itself has not been changed, thus is not resaving. For instance, if you had the auto-title feature disabled and created a handful of documents without titling them, turning this feature on and then saving would not affect their titles since nothing has changed in the document text since the last time they were saved. When the project saves (auto or manual), only documents that have been changed since the last save are re-saved. So in this case, you’d need to edit each of those documents so that Scrivener saved the changes, and then on that save the document would also be auto-titled.

If you have a different case of the auto-titling not happening, is there any pattern you notice about which documents do auto-title correctly and which do not, or when it works and when it doesn’t?

Dear Jennifer:

I will keep an eye on this and let you know. Thank you.

Liz

Do these rules apply to the Mac too?

Only the last one.