<b30> Scrivener not saving column settings for Outliner Mode

I’ve had this happen to me several times now.
In Outliner Mode, I don’t want to see (for example) creation date and modification date for documents, but when I re-open my manuscript, the selections are back to what I assume to be the defaults.

I tested after installing b31, and the settings were saved as expected.
That said, the manuscript was probably last saved in b30, so I have no idea why I had this problem on multiple occasions.

Whatever the reason, it appears to work now.