Backup Problems

I’m using Scrivener 2.5, and have my preferences set to backup on exit. The directory is my Dropbox folder. This has worked perfectly until recently–but now the only way my files will back up is if I trigger a backup manually. I have uninstalled/reinstalled the software, restarted numerous times, checked and unchecked the boxes, but when I close a project, though it should backup, it merely closes. Please help! (This behavior started this weekend, and coincidentally (or not) I recently updated to Mavericks.)


Could you check in the File/Back Up/ sub-menu and ensure that there is not a checkmark beside the option to exclude the project from automatic backups? It sounds like this got turned on accidentally, as that is exactly what will happen. The manual “Back Up Now” method will always work if you ask it do, as well “Back Up To…” but any scheduled backups will be ignored by the project. Useful if it’s a couple of gigabytes or something.

Hi Amber,
I checked, but there is no place for a checkmark next to the exclude option. I can check on it (and have, to test), but the next time the file is opened the only option again is “exclude”. And it is working the same for all projects. I opened four different projects and hit Quit from the Scrivener menu, and the program quit almost immediately, with no backups triggered. It’s a mystery…

To clarify, these are my default settings:

Turn on automatic backups

Backup on Close

(Which is a legitimate and active path)

Sorry for that, I could have sworn that once had a checkmark when it was enabled. I think that might actually be a mistake, since there is no way to tell if it is on or off right now.

Okay, when you are manually making a backup, which method are you using? Just the File/Back Up/Back Up Now command (or the toolbar button)?

Yes, I’m using File/Back Up/Back Up Now.

Okay, so functionally the manual backups are being created in an identical fashion to how automatic backups should be. It sounds like we might have a bug here. The first thing I would do is go into the General preference pane and enable “Show internal errors”, at the very bottom. If anything goes wrong with Scrivener internally, this will let you know. It’s off by default as it can be a little over-aggressive in its reporting. But when there are known problems that is what we want!

Secondly, go to Finder and use the Go menu to access Utilities. Double-click the “Console” icon, and leave that running while you open and close your test projects. If you get any messages, either from internal errors or through the regular error reporting in console, paste them here.

I activated console, and the messages were popping in faster than I could read them! Seems my computer was a mess…

The biggest offenders were MacKeeper (which I stupidly installed in a last-ditch effort to stave off Mavericks) and something called CleanApp, which I don’t recall installing. I deleted all instances of those, fixed a few other things, restarted, and went off to test Scrivener. Success! The files opened and saved upon close, just as intended. Obviously, something in the mess I’d created was preventing the proper function, but there were so many errors, I still don’t know exactly what. Everything is now back to normal.

Thank you so much for solving far more than my Scrivener problem. Have a great weekend!

Ah, those kinds of programs can make a mess. How strange that it impacted Scrivener in this way though, but I’m glad it’s all working better now. :slight_smile: