Backup Project to . . . Zip problem [RESOLVED]

Overall, loving this! That said, running into problems with backups, as follows:
Using Scrivener for Windows on laptop running Vista

1)Selected “Backup Project to”, checked to save as Zip file and hit okay.

Then, tried to access the backup:

2)Right-clicked on the Zipped file and selected “Extract Compressed Folders”
3)Changed the destination folder to something completely new, hit next
4)Error pops up “There is already a file with the same name you specified. Specify another name. Flex.scriv, Type: SCRIV file”
5) I am then left with only a file (not folder) that is named flex.scriv. If I click on it, windows doesn’t know how to open it.

If I try instead of 2-4, to

1)navigate inside the compressed folder, copy the folder that says flex.scriv, and then paste it directly inside a new (empty) directory.
2)I get the same duplicate file error message, but then, after canceling, I will now have an uncompressed folder named flex.scriv.
3)If I open that folder, I will see the project file, along with subfolders.
4)If I double click on the project file, it says “Project project is incompatible with this version of Scrivener.”

I can not, at this time use any of the projects that I’ve tried backing up in zipped form. Normal, uncompressed backups work fine.

Edited to add, same problem when trying to unzip the NaNoWriMo template, unfortunately.
Incompatible version error.pdf (21.2 KB)
Duplicate file error screenshot.pdf (194 KB)

Okay, this morning I did some more investigating. I installed Scrivener on my desktop (also running Vista), and the same files (transferred through Dropbox) work just fine. There is no duplicate file.

Very strange, no idea what could be causing the issue on the laptop, but will keep investigating and let you know if I figure anything out.

For some reason, on the laptop the zip folder appears to contain two items instead of the single folder that my other computer shows. One is a folder named flex.scriv - and the other is an empty file with the same name. This file doesn’t exist when I view the contents of the zipped file on my desktop. I have no capability to delete the extra file - nothing happens. I can’t rename it, either.

When I try extracting the files, only the empty file copies successfully - apparently it is extracted before the folder, and the folder is then considered a duplicate.

When I do a copy and paste of just the flex.scriv folder that is inside the zip file, it gives the same error message, but this time the folder copies “successfully”. Unfortunately, when I then go into the newly “unzipped” folder and try to run the project file, it gives me the incompatible version error.

Is my computer having a hard time with the directory naming scheme? Don’t know yet. Will do some more poking around, later, trying some other zipped files, not just Scrivener ones.

Created several zip files that the laptop still handles with no problem. Even tried renaming some of the folders with the .scriv extension before zipping. No problem.

Then I manually compressed the project folder that I’m working with on my computer. Was able to then extract and work with the project files just fine, no problems. (Though if I try to navigate into the directory while it is still compressed and double click the project file from there, I get the incompatible version error. Once I’ve extracted properly, the project file works as expected.)

The only time I’m seeing this duplicate file error on my computer is when accessing zipped files that were created by Scrivener.

For now, I can work around by zipping my backups manually. And if I want to download the nanowrimo template, I can just unzip it on my desktop and then transfer the unzipped files via dropbox. (hopefully!)

Yay! Problem with unzipping files created by Scrivener on my laptop was solved when I received, downloaded, and installed Vista Service Pack 2. So if anyone else has this issue, that’s the key! :smiley:

That’s a relief as I was not able to duplicate the errors despite diligently following your detail. Thank you.