Backups Will Not Open -- HELP!

I am having an ongoing problem with my saved backups. It has become a day by day situation because I never know if a newly saved file will open or not. Some days, they will. Other days, I see this:

"The project you are trying to load uses an older format and cannot be opened. Would you like to update it?

I click on “Update Project.”

I get another error that says “Warning: This project was either not closed properly or is currently open on another machine.” Scrivener offers to “re-synchronize the search strings”. I click “OK.” Nothing happens.

I have had to rebuild my project several times from text edit and older files that would open. It seems that I never had this problem until I upgraded to 1.51. I’m wondering if my software is somehow corrupted?

Can I reinstall a “clean” version of 1.51 or go back to the older version?

Are you choosing to zip the backup or not? If not, do you definitely have enough disk space? In either case, where are you saving your backups to? The local hard drive or somewhere else?

Please note that I’m on holiday at the moment so may not be able to reply as quickly as usual.

All the best,
Keith

Yes, I am saving the backups as zips. Besides the local hard drive, I also have two external hard drives. I actually save backups on all three drives. There is more than enough disc space. (To open my project, I use the backup on the local drive).

I did reinstall 1.51 yesterday. It worked perfectly for one day. Tonight, I saved my updated work as a new zip file. I closed Scrivener. I then clicked to open the zip file. Then I clicked on the .scriv file and got the exact same error as before.

Thankfully, a zip file saved yesterday will open. I used text edit to copy and paste the updated writing into the project.

Any thoughts?

Just a thought.

  1. Quit scrivener.
  2. find project file in finder.
  3. Duplicate project (you should now have a “copy of”)
  4. ctl-click “copy of” and click compress (this should make a zip file)
  5. Now try to open the backup.

On another though, it isn’t possible that you have 2 versions of scrivener install is it? Try a spot light for scrivener. There should only be one listed in the applications section.

Hi, any updates on this issue? I am having the same issue. I updated my copy of scrivener and ever since have not been able to open any of my existing scrivener files… I actually got the same exact message as the one posted above.

Thanks for the help!

Which system are you using?

Could you please give more details? The syncrhonise search strings message is harmless; if you continually receive an “update” message though, even after updating a project, that indicates a corrupt project. Please describe everything you’ve done and exactly what’s happening.
Thanks,
Keith

I have another slant on on save. I want my saves to go also to a safety separate hard disc.
At the moment they are going to Time Machine which does not enable me to find the saved file.
Unfortunately I cannot read files from the special safety hard disc which I call Mt Passport ! It is wired up and appears on my desktop!
Can you help me please
Robin In Cornwall U.K.

Time Machine allows you you to look at each incremental save to the individual file level so not certain what your issue is there.

You project saves (as opposed to ZIP backups) should always be to a local drive and if you ever need to recover a project from a ZIP backup you should always expand it to the project save location on the local drive. (usual warnings about project name conflicts)

One additional point. If you are having any issue getting at individual files on your Time Machine backup, don’t muck around and potentially make matters worse - phone AppleCare or better yet, download the support app or go to their support page and book them to call you. One point, due to covid support hours are reduced in some regions and if you call outside regular business hours you might find you are talking to a whole other part of the world. Not an issue in itself unless a particularly region specific issue arises.