backward compatibility with files

I know developers hate to do this, but could you make each new version compatible with existing .scriv files? I know that the latest version converts to the new format, but when you have dozens of files in different places (laptop, main computer, backups, dropbox, onedrive etc) it becomes a pain to manually delete all the old files after they have been duplicated in the new.

It would work more smoothly for the user if scrivener simply read and loaded old files and you were then given the option of saving in the old format or overwriting in the new, same as most WPs.

Thanks.
Genghis