bad trouble, end of the world -- Scrivener won't run

how it has acted: sometimes crashed before I have opened a file, other times as soon as I have opened one.

to fix it, so far I have tried:

  • closing down and restarting the MacBook
  • tried opening different Scrivener files
  • logging out and trying Scrivener using a different account

also I have sent a bug report. possibly relevant information:

  • earlier today I changed the default icons on my Mac
  • I also deleted the account belonging to the original owner, who owned the MacBook before me

really very much hoping that I can resolve the problem, of course.

Hello,

Sorry to hear you’re having problems. How many files is this affecting? Do you use page layout mode? Had you created any tables in page layout mode? What version of OS X are you running? Could you please send a zipped-up copy of one of your crashing projects to support@literatureandlatte.com?

Thanks and all the best,
Keith

every one that I have tried opening, and I have tried, I think, four so far. when I have tried creating a blank new Scrivener file as a test, those have also crashed.

yes.

never.

10.6.6.

will do.

Did this happen immediately after updating? If so, it may just be a bad install. Try re-downloading and re-installing from literatureandlatte.com/scrivener.php.

All the best,
Keith

I have had this version of Scrivener (2.0.2) installed for a while now. do you think it would help if I reverted to an earlier version?

I’d try deleting your preferences–or move them somewhere other than the default directory–and seeing if that doesn’t fix the problem. Or upgrade to 2.0.4…

thank you.

I had already gotten these suggestions in a private e-mail. neither solution worked. (I might have actually DL’ed a more recent version of Scrivener, though, anyway.)

If you haven’t already, try re-downloading and re-installing anyway. If you had version 2.0.2 and then updated - because 2.0.4 was out the other day - and then the update didn’t download and install properly, then Scrivener would no longer run until you re-downloaded and re-installed. Let me know if you’ve already tried this.

Thanks,
Keith

a little bit of a late response because I did not have time to go online yesterday. according to the “about Scrivener” box, I had managed to DL 2.0.4. (of course, I already had 2.0.4 and erred when I said I had 2.0.2.)

now that I can actually find the preferences files mentioned (thanks to tech support e-mail), I will try doing as suggested. I have a hunch that will fix everything.