Basic text wrapping problem!

When I am working on a document and typing, the line never automatically jumps down like it would in a word processing program. It just goes endlessly off to the right, even though it’s going off the edge of the document. Somehow I’ve lost basic text wrapping. I’ve already tried going under Documents and converting the formatting to the default text style. For some reason, that isn’t working.

Any suggestions?!? I’m stumped!!

Does the screen still follow your typing even though it isn’t word wrapping? By that I mean, can you still see what you are typing in, or is it going off the window entirely so you can’t see what you are doing? If it is the former, do you have a scrollbar at the bottom of the window? If so, perhaps you are using a very wide Page View setting, or potentially Fixed Width. If you check the View/Page View/ sub-menu, does it say “Hide Page View” and if so, which of the two items below has a checkmark beside it?

Thank you for your reply, AmberV. When I type a long line of text, it just disappeared at the end of the window. I’m pretty sure there was no scroll bar at the bottom.

Now that I open the project a second time, the text is wrapping just fine. When I drag the corner of the window to make it different widths, the text adjusts automatically and I can see all the text. This is precisely what it WASN’T doing yesterday.

So it appears at least for now that the problem is “fixed,” but I’d still be interested in knowing what might have caused it, if anyone has any ideas.

Thank you!

P.S. To answer your other question, under Page View it says “Show Page View.”

Okay, yeah sounds like a display bug then. Are you using Lion and Scrivener 2.1?

I recall a bug like this one with either 2.1 or one of the earlier 2.1.1 betas. Downloading the latest beta from the “Beta-Testing” should fix it.

All the best,
Keith

Hi

I’ve just started, after a week or so of downloading Scrivener 2.1 from the App Store, getting this same problem. Did downloading the beta fix it, and if so, where do I find it? I can’t see a beta download link on the site.

Thanks

Simon

Hi Simon,

Actually, I didn’t think this problem would be in the 2.1 Mac App Store version, so it might be something different. Is this in the regular window or in composition mode? And are you using page layout mode or not? Could you please post a screenshot?

The beta can be downloaded from here:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

Note that if you do download the beta, it uses the regular update methods rather than the App Store mechanism, so when 2.2 is released via the App Store you will need to delete the beta and install again from the App Store. The beta will recognise your Mac App Store licence though.

All the best,
Keith

Hi

This isn’t a very useful screenshot. I think it only happens when I create a new text document and start typing on the first line. The text disappears off to the right, never wrapping round, and with no scroll bar appearing at the bottom. If I close Scrivener and restart it, go to the same text document and start typing, then the text starts wrapping round, as do all subsequent lines.

What the screenshot shows, therefore, is a new text document with a single line, but the text in the line goes off to the right and out of sight. There’s no way to see this text. Does it give any clues as to the problem?

This is another screenshot, in Page View mode (if I’ve understood it correctly) but is slightly better. Here the text has just started to go off to the right, and you can see how the cursor and the last visible character have become slightly overlaid.

Regards

Simon

That’s very weird. Could you please do the following?

  1. Go to Scrivener > Preferences…, click on “Manage…” at the bottom, choose “Save All Preferences…”, save the preferences to a file, and then attach the resulting file to your reply (using the “Unpload attachment” tab underneath the box in which you type your reply).

  2. Try out the beta to see if that does fix things.

I think it’s either a) a problem that I fixed in the beta (although I don’t’ recall seeing this in page layout mode ever before) or b) a preferences issue.

Thanks,
Keith

Hi Keith,

Here’s my preferences file. Perversely, I’m hoping it’s just something oddball I’ve done in my preferences without realising it!

Thanks for your help,

Simon

Have you tried turning on the ruler to see where the right margin mark is?

Mark

PS No pun intended

Tried turning on the ruler, but the text goes past the right margin mark and disappears as before.

Just wondered 'cos you’d got no ruler showing in your screenshots.

Mark

Hi Simon,

The preferences file doesn’t seem to be attached. Make sure you click “Add the file” after choosing it. Thanks!

All the best,
Keith

ah - upload attachments doesn’t like files with .prefs prefixes. i’ve renamed the file prefs.txt and (hopefully) attached it here
prefs.txt (26.6 KB)

Hi Simon,

Thanks for that. I’ve tried loading them, but so far everything seems fine for me. I’ve only tried on recent builds, though, not yet on the 2.1 that would have been the Mac App Store build. Have you tried the beta yet to see if that fixes it?

Thanks,
Keith

Just to add a postscript to this story. I thought I was going to have to live with the problem, which, in essence, was that the cursor would disappear off to the right of the editing pane (with no scroll bar) - but only on the first line of a new text document. My only solution seemed to be to write the first line, then close Scrivener and then restart it.

Today, I reset all my Scrivener preferences to default, and this seems to have cleared the problem. So the problem was something to do with the way I’d previously changed my preferences, but I can’t remember what it was that I had changed!

Thanks to everyone who helped!

Simon