[BB] Compile to Word turns em dashes into double hyphens

I can’t find the setting that’s causing this. In my Scrivener 3 beta for Windows document, I have em dashes. But when I compile it to MS Word Novel format, they all get changed to double hyphens. That’s the opposite of what you normally want to happen. I’m on the latest beta that will expire at the end of July.

Sorry for taking so long to reply to this issue. Are you still experiencing this in the latest beta?

Sorry, I finished my novel and haven’t started the next one yet. Yes, this was an old post!

Yes, I am experiencing this in .docx compiles with Beta 10. I’ve not tried it with a .doc compile.

Win 10 v1803

Possibly related to this, I’ve found copying as MarkDown also converts em-dashes unexpectedly, in this case to triple-hyphens.

Hi Twolane and Collider, are you both using the default compile format? Or have you made modifications? If you have could you send me either a screenshot of your format options or a copy of a project with the problem? The project can be sent to win3beta@literatureandlatte.com, the screenshots can just be posted here.

Thank you for your help in tracking this down!

Can confirm I’m sticking to the default Compile settings across the board, not changing anything or checking / unchecking any boxes… the only exception being, on occasion, to select specific document(s) vs. the entire MS.

If it helps, the problem seems to occur universally, across Scrivener projects. And when using ‘copy as Markdown’ (via the ‘edit > copy special’ menus), the em-dashes display consistently as a triple-hyphen in every program I paste into, whether a Markdown-specific or generic text editor.

I’m not doing anything special with the compile formatting for the .docx. I use it to upload to my phone and reader for reading drafts.

Formats: Manuscript (Times);
Font Times New Roman;
Available Layouts (Unassigned);
Choose which documents should be compiled;
Compile: Manuscript;
No front matter;
No back matter.

I tested a .doc as well as a .docx. Both do the double hyphen conversion with the same settings.

EDITED TO ADD: Word 2010.

Confirmed - I’m not seeing anything new I can report, so I won’t load you up with screenshots or other stuff. I did a test compile on default settings to .docx and all the em dashes became double hyphens.

FWIW, I’m using Word 2016.

Thanks for all the great stuff you all are doing!