[BB] Weird graphical error in font in some parts of the text

In one of my projects, I have this weird font graphical bug. Some of the text even within the same paragraph looks like this:

When I copy this kind of text and paste it somewhere, the weird look gets pasted with it so it’s some text formatting I guess. However, when I move the cursor between normal text and this kind of text, nothing changes in the top bar so I don’t know which font setting I should look for. (font and its settings stay the same)

Does it look any familiar, what this could be?

Version: Beta (149671) 64-bit

Hello! Does this occur with multiple fonts or is there one in particular that you have noticed? Are any styles applied either before or after this issue appears?

Thank you for your help with this.

I have a similar problem. By default, I use the Linux Libertine font in everything. When I close Scrivener and then open it again, all my italics turn into Linux Libertine Initials. I haven’t tried it with a different font yet - will do it later - but this only happens with the italics.

For the initial poster, it looks like some of the text has the “Outline” formatting applied to it, You can toggle it off in Format > Font > Outline.

The second issue, involving the font changing, sounds like a different problem, with the font recognition. I would try testing with a different font, using the same steps as you do with the Linux Libertine, but my guess is that the italics will remain as expected. Do you happen to have an oblique variant of the Linux Libertine font installed? Or if you choose from the dropdown menu to the right of the font family on the format bar, what options do you have listed there–just “Regular”?

I tested it with a couple of most common fonts and the italics worked fine, I didn’t test it with any other font I have a lot of similar options, though (I have Linux Libertine, Linux Libertine Display, Linux Libertine Display Capitals, Linux Libertine Initials and Linus Libertine Slanted). And yes, I do have an oblique variant for the default font.
It’s not really a problem and I’m still using the font because I like it anyway, just thought I would mention it, since at first look it seemed a similar problem.


I’m sorry, I had the notifications off for this thread! The issue was that it had outline on and that solved it. Thank you very much! :slight_smile:

Hi, Thaischristabel:

I had the same problem using Linux Libertine in the Mac version 1 of Scrivener years ago, which leads me to suspect the problem is with the font and not (just) with Scrivener.

Fortunately, everything started working as expected when I switched to using the OpenType version of Linux Libertine rather than the TrueType version. Sourceforge seems to want to give you only the TrueType version by default, but you can still navigate to the latest version of the files and download the archive file with “OTF” in the name instead of “TTF”. Once you install the fonts, they’ll show up in your font dialogues as “Linux Libertine O” (and so on) instead of “Linux Libertine” or “Linux Libertine G”. (The OTF version might be worth using anyway just to avoid the hassles that sometimes result from the fact that the TTF version can’t make up its mind what its name should be on Windows.)

I haven’t got around to trying it yet, but you might also want to consider Libertinus — a fork of Linux Libertine that a different group of developers has continued to update since 2012.

– Kevin

PS: And props to the developers for the fact that the OpenType version of Linux Libertine, like many other OpenType fonts, no longer looks like crap on Windows, the way it did in version 1!