BBC Radio Scene Style Formatting Issues

The formatting for radio scripts isn’t working properly.
The names get added to auto complete and have a colon appear after them. But each time a name is used thereafter there is no colon, and the auto complete list for names containing @FRED’ for example, list all instances 'FRED@ has been used in the whole script, including the following dialogue. So each listing under FRED contains every time it has been used in including the following dialogue. Of course I would like only one instance of ‘FRED’ to be in the auto complete suggestion list when adding a character on a Character element line. I have tried amending this in the script settings, but cannot find a way around it.

Please advise.