Best way to block quote in 2.0

I know this has been asked a million times (I just spent two hours reading through the forum), but most of the tips were about earlier versions of Scrivener with Styles and not Presets.

What I’d like to achieve is simple: a block quote that is indented on the left and right.

This is what I tried and don’t understand:

  1. Here I can apply the block quote or essay block quote (preserved) preset, but I don’t get a right indent. How do I add it? Also, is there a way to see all settings of a preset? I don’t want to apply block quote and all seems good, but all of a sudden it changed something in my formatting that I don’t understand.

  2. Here I can use Scriptwriting mode. Is that still necessary in 2.0? What does this mode do? Is there a reason why I shouldn’t use it?

Hi,

To answer the second question first, you could use scriptwriting mode in this way - some users have hijacked it to act as a sort of styles system, seeing as Scrivener doesn’t have a true styles system (that’s on the list for a vague future version when we have more time and resources). But you’d need to set up your own scriptwriting format and then the system is very much designed for scriptwriting needs, so you may run into limitations.

A better solution is to use presets, as you mention. The default “Block Quote” format in the presets doesn’t have a right indent, as it’s designed for APA and MLA formatting mainly. But you can set it up however you want. There’s no way of viewing all the settings of a preset, because it’s all done through the editor. You format some text in the editor, and then use that to create the preset. When you apply a preset to text, you will see the settings it has applied reflected in the ruler and the format bar.

A good tip when setting up presets is to add the “Preserve Formatting” attribute to the text if you want the text to keep its formatting when compiled if you are overriding formatting during the compile process. (And if you aren’t overriding the formatting, the “Preserve Formatting” attribute has no effect, so it doesn’t hurt to use it.) So, for example:

  1. Set up some text as you want it for the block quote in the editor. For the right indent, you just use the ruler to move the indent marker (the blue downwards-pointing triangle on the right of the ruler - or grey if you are using the Graphite OS X theme).

  2. If you want the format preserved even during compile, select the text and go to Format > Formatting > Preserve Formatting.

  3. With the cursor in the correctly-formatted text, go to Format > Formatting > New Preset From Selection. Alternatively, choose Format > Formatting > Redefine Preset From Selection to change an existing preset.

  4. You will now be presented with a sheet with some options. You can give the preset a name, choose whether it affects all formatting (“Save all formatting”) or not (for a block quote, you will probably only want to save the paragraph formatting in the preset, so choose that option), and whether you want to include the font or font size (you probably don’t for a block quote).

Save the preset, and after that you can apply the block quote preset to any text in any project.

Hope that helps.

All the best,
Keith

This helps a lot. Thanks. I’ll play around with it more properly over the next few days.

One more question, though: the indent markers depend on my current zoom level, don’t they? So both left and right indent change when I switch from laptop screen (at 200%) to my external screen (at 300%). How do I circumvent that problem?

You set indents to a certain value, say 1 inch (or cm) on the left, right border of the text body minus 1 inch on the right for a block quote.

These settings won’t change if you zoom in or out. If the ruler is visible (cmd+R will make it visible if it’s not) you can see that it is zoomed in or out too, including the blue border, indent, and tab indicators.

Hmm… doesn’t seem to work for me. Do I have to be using ‘page view’ for that to work? Because I’m not using it and the ruler does change depending on the zoom level.

Page view is something different.

Like I said, the ruler does change when you zoom. Zoom is like a magnifying glass you hold over the “paper” and the ruler and both look bigger when you look through it.

When you set the indent to 1 inch this setting won’t change if you zoom in. Only the inch will get bigger.

Zoom is only a view mode and does not have any effect on printing of the text.

Hi,

The ruler doesn’t change as you zoom. You may see more markers in there, that’s all. At 100% zoom you might only be able to see quarter-inch marks, for instance, whereas at 200% you might see tenth-inch marks. Zoom has no effect on the actual value of the indent though.

All the best,
Keith

OK, I think I know where my confusion stems from: I can’t set an indent to 1cm from the right, can I? I need to move the marker to, let’s say, 15cm from the left, correct? Which means I need to know in advance what the page margins will be in my final Word document, and I haven’t thought that far ahead yet.
Am I right here?

Yes, that’s right - that’s a limitation of the text system, I’m afraid, and the way its ruler works.

This limitation means that it’s usually better to use only a left indent. Otherwise if the margins are large in Word (or whichever application you are sending the final rtf file to) the text may stick out beyond the right margin.

If your blockquotes need to have a right indentation, then it’s fairly easy to do that once you have them in Word, by searching and replacing paragraph formatting.