Beta 035: Copy and Paste Outside Source

I don’t know if this is a bug or an operator error, but when I copy and paste from an outside source, like a website or a Word document, the formatting isn’t automatically changed to fit the Scrivener editor. Basically, it looks like there is a return halfway through each line across the page, so the text only goes halfway across the editor.

I can’t find the right part of the program where I could manually change the format. It looks like, when the source is from a website, I can add onto the end of a line and my typing will span the entire editor, though the pasted portion of text still has the returns throughout. When the source is a Word document, I can’t even write past the end of a line of pasted text. It takes me to the next line down.

I hope this makes sense. Is there a setting or something I can do to fix this or is a bug?

A regular paste will preserve the formatting, so what you probably want to use is Paste and Match Style, which strips all formatting. This includes character formatting like bold and italic, though, so if you do need to preserve that then you could use Documents>Convert>Formatting to Default Text Style after you’ve finished pasting to bring the whole document into sync with your current editor defaults (defined in the Editor tab of Tools>Options). You could also try turning on the ruler (Format>Show Ruler) to check where the indents are set–that might be the problem for the Word paste, that the right indent is too far left, and you can fix it by selecting the text and then dragging the marker on the ruler. (Make sure to place the cursor in the problem paragraph when you check the ruler, since paragraphs can all be set differently.) Also Format>Options>Show Invisibles will display any paragraph or line breaks that are in the pasted text, which can sometimes come in from things like received emails and so forth that use hard breaks instead of line wrapping.