Hi Beta Testers,

I have uploaded beta 049. This is available as an update via Scrivener menu Help > Check for Updates or as a full install package from
(Please remember to refresh your browser cache)

You can install over 046 if you wish if you download the full package.
NOTE: NEITHER OF THESE DOWNLOADS ARE FOR THE NANOWRO VERSION. There will be a separate full install package prepared and put up on the NaNo pages.

[u]When I posted this yesterday evening I did not realise that 035 had not expired. I had assumed everyone was on at least version 045. In light of this, if you are running 035 you can’t use the check for updates feature but must use the full installer and can install straight over the top of 035. If you are running 045 or 046 you can use the check for update feature.

The update only contains three files: QtGui.dll, Scrivener.exe and the readme.txt. The full installer has a bunch of new files that are needed for 045 onward.

My apologies for missing this.[/u]

This beta has many fixes since 046 was released earlier this week. The reason for such a frequent release is to ensure the product is robust enough for release. 046 had some issues that caused a crash due to our adding support for double width character code pages. There was also some crashing issues with Scrivener importing invalid encoded characters that have now been fixed.

I will start working on the special NaNo build and get that up later today which will run on the same code base.

There are the following fixes also in 049:

FIXED->Drag and drop images to project and document notes enabled.

FIXED->Updated the code to handle invalid encoded characters on import, save and export. Also added an Option to remove invalid characters or replace them with the standard unicode symbol for invalid character (a diamond with a question mark in it).This was causing Scrivener to crash when it would try to lookup the invalid character in the font tables to determine how to draw it to screen.

FIXED->The font matching algorythm has been improved to match to the closest font possible based on the font family name. Obviously fonts that don’t exist on the importing system that might exist in an imported file from elsewhere can’t be matched to an exact font, but the closest family name and style.

REALLY FIXED NOW->If you have a multiple selection open on the corkboard, dragging and dropping the cards in the corkboard does not appear to move them on the corkboard but does move them around in the binder. Dragging and dropping on the corkboard or outliner should not be allowed when viewing a multiple selection, i.e. it should not look like it’s possible and it definitely should not do anything to rearrange the documents. This bug applies to the outliner as well as the corkboard.

FIXED->URLs still pasted twice into rich-text fields when copied from omnibar in Chrome.
EXPLAINATION: Chrome is sending this as uri’s
This doesn’t appear to be correct to the spec for uri’s. 0a translates to \n, so we can avoid it by checking for \n in the url retrieved as we shouldn’t ever get one anyway, and if we do its probably a chrome style uri. If someone does find something in the uri specs that allows for a \n to mean something then let me know and I’ll add it.

FIXED->Corkboard seems to get slightly rearranged on close–e.g I set it to “3” across and it reverts to “auto”; it also tends to scroll back to the top even when I closed with it partway down, but this might be unavoidable?

FIXED->Ghost notes on/off setting is not being remembered on project close/open; it should be.

FIXED->Outliner columns displayed in the order they are added.

FIXED->It’s possible for text on synopses to get hidden behind the keyword stripes on the corkboard i.e. View>Corkboard Options>Show Keyword Colors. This happens when card ratio is change (e.g. I’m seeing it a lot around 6x5) but there should be some margin on the edge of the cards to prevent this regardless of size or ratio–the line wrap needs to change when keywords are displayed.

FIXED->Sometimes, clicking on a row will cause the outliner to scroll horizontally, so that the left of the synopsis is visible but the title column is now off-screen (even though you clicked on the title or icon). This is annoying and slightly confusing.
If you have scrolled it to the right so that the synopsis column is visible and the title column is not visible (scrolled offscreen to the left), then double-click to edit the synopsis, the synopsis editable area starts off-screen to the left. In other words, the editable box’s left and right edges aren’t lined up with the left and right edges of the synopsis column in this instance, making it very awkward to edit.

FIXED->If you resize the synopsis column in outliner, the height of the cells doesn’t automatically adjust to show all of the synopsis. You have to click on another document and reload the folder to get the rows to change heights. When the outliner column is resized, the heights of the rows should adjust to show all the synopses (you don’t want to do this live, which can be slow, but just to reload the heights once the width resizing has been finished).

FIXED->New Project panel doesn’t close when selecting a project from the Recent Projects list

FIXED->There seems to be some issue with specific characters being used for smart quotes/apostrophes, em-dashes, and ellipses that causes them not to appear in the editor when the file is imported into Scrivener, and working in the document then often causes a crash, or become very laggy. We’ve had about a dosen reports of this in the forums since beta 046 released.
EXPLAINATION: All three issues where a signed/unsigned issue, char instead of uchar. Bug would have come in when support was added for double width character code pages.

FIXED->Hitting “Cancel” when searching through existing documents to open in the New Project panel closes the whole New Project panel rather than just canceling out of the file browser

FIXED->If columns are added to outliner via the menu and they are added off-screen the interface should scroll across so the newly added column is visible.

FIXED->1. Ruler bug - Type a few letters in a new document A
2. Create a subdocument for that first doc
3. Load Document A in single document view and note the editor–should look normal
4. Switch to Scrivenings view–the ruler suddenly shortens when the focus is in the container docuemnt A (if the focus is in the subdocument, the ruler returns to normal)
This seems related to how much text is in the container document–if you start typing there while in Scrivenings, you’ll see the ruler snap back to the full width of the editor, but if you delete them, click to another document in the binder, and then click back to reload the Scrivenings session, the ruler will be short again. (Screenshot attached showing the shortened ruler).

FIXED->The error message on epub and mobi compile explaining that the user needs to fill in Title, Author, and Date in the meta-data is missing, so clicking “Compile” when those fields are empty does nothing at all.

FIXED->1. Load a doc stack in the editor, single doc view, hide ruler
2. Switch to Scrivenings mode
The ruler reappears–it should not. The ruler should be set and remembered per-editor, with the single document view and the Scrivenings view using the same settings. This applies to full screen as well, which is a third editor–its settings should be independent of the regular editor splits.

FIXED->If a document/folder is selected on the corkboard and a file is imported to the project by drag and drop onto the corkboard, it imports 16 copies in the file. (If multiple folders are selected on the corkboard and a file is imported to the corkboard via drag and drop, it imports to both the selected folders for a total of sixteen copies in each folder.).

FIXED->“Select All” doesn’t work for converting multiple spaces to space or other Format>Convert options (it’s necessary instead to manually select all) - all the formatting conversions here should a) be available to apply to the entire document even when no text is selected, b) work anyway if “select all” is used, and c) apply to just the selected text when that is only a portion of the document selected.

FIXED->Clicking “Abort” or hitting the Esc key when Project Statistics are compiling can cause a crash. I wasn’t able to get this in smaller projects, but it seems reproducible in the Tutorial project. So to see this, create a new tutorial project, then open Project Statistics and click “Abort” before it finishes compiling. At first it seems okay, but as soon as you click somewhere else in the interface, Scrivener crashes.

FIXED->Inspector/keyword bug in Full Screen:

  1. In FS, click the icon to open keywords
  2. Click the icon to open the inspector.
    The inspector opens but keywords closes. Or rather, it doesn’t close, it just hides behind full screen, so it takes two clicks on the keywords icon to bring it back.

FIXED->Between paragraph spacing set in the editor is being used in compile when it should get overridden

FIXED->No space between footnote number and footnote text (likewise when compiled as endnotes); there should always be a single space (PDF, RTF)

FIXED->“End of Text” marker is picking up a first-line indent from the other text formatting whereas it should have none and be centered (PDF, RTF)

FIXED->PDF endnotes use a superscript Arabic numeral followed by a period. This should either be one or the other–superscript and no period or not superscript and have a period.

PARTIALLY->Endnotes in PDF are not picking up the proper font and line-spacing from the main text (they remain single-spaced and use their font from the editor)

FIXED->When modifying formatting in the compiler, alterations made before clicking the “Title Settings” button are lost (e.g. Click “Modify”, click in the text and change alignment for the body text, click “Title Settings” and add a prefix, click OK to the title settings, alignment for the main text has reverted)

FIXED->Fixes installer issue not deleting all Scrivener registry keys.

FIXED->Every time a script element is modified in the Script Settings panel, the entire list gets replicated in the pop-up menus in the Tab/Return tab.

FIXED->To summarize earlier Mac-related issues I was experiencing, since I don’t think I updated Keith on this, I’m hitting two problems: First, when working with certain Mac-originated projects, I start getting constant crashing from random-seeming triggers, not specifically reproducible but fairly reliable as far as “open the project, mess around in the document for a few minutes, crash Scrivener”. I’m pretty sure though that it was all related to editing particular text files in the project rather than clicking various parts of the interface, etc., and these were documents that exhibited the second issue.
FEEDBACK->this whole bug relates to the now fixed issue of not importing ascii 1252 correctly.

FIXED->Can’t “Duplicate” on multiple selection in the binder.

FIXED->It looks like the <$n> and <$sn> tags work fine for this, but if the variables are capitalized (as they are in some of the templates), then the numbering doesn’t restart. Uppercase and lowercase behavior for these tags should be the same, matching the current lowercase behavior.

So to see this:

  1. Create a blank project
  2. Type <$N> into the first document
  3. Create a second document and type <$SN> in it
  4. Duplicate the <$N> document once and the <$SN> document several times, then rearrange the binder so they’re ordered <$N>, <$SN>, <$SN>, <$N>, <$SN> etc.
  5. Compile with the default settings–just running a Preview is enough to see this

The numbering comes out as 1, 1, 2, 2, 3.

Doing the same with lowercase variables outputs correctly as 1, 1, 2, 2, 1.

It looks like the problem is the <$N> variable. If you run the scenario using the lowercase <$sn> but uppercase <$N> you get the same problem, so it seems like <$N> just isn’t being recognized by the <$sn>/<$SN> variable to induce a restart.

FIXED->Option for disallowing drop-ons on corkboard doesn’t work–drop-ons are accepted regardless of whether this box is checked or not.

FIXED->a) When you switch to scrivenings mode from the outliner or corkboard, if there was a selection on the corkboard or outliner, place the cursor at the start of the text of the (first) document that was selected on the corkboard or outliner, and scroll the view so that the top of the text of that document is visible.

b) When you switch out of scrivenings mode to the corkboard or outliner, select (and scroll to) the card or row that represents the text item that had the cursor/caret in it in scrivenings mode.

In this way, the user can easily navigate scrivenings by quickly switching to the outliner or corkboard, selecting a row or card, and then switching back to scrivenings mode again.


28th Oct 2011

Thanks Lee.

I couldn’t get the Help > Check for Updates method to work (“host cannot be found” - possibly due to a work firewall?) but I’ve downloaded the installer manually and all is good.

Looking forward to giving you some money for this thing!

Check for Updates within the program worked great for me. Unfortunately I was using the Nano version. If there was a warning to not update if you are using the Nano version, I completely missed it.

EDITED TO ADD (since I was still mostly asleep when I did this this morning): I frequently check for program updates from within programs I use. I didn’t update because I read about an update anywhere. I just got ‘lucky’ first thing this morning.

Wow. Two betas and lots of fixes this week. Lee you’ve been working insanely had and it IS appreciated.
downloading 049 now

Downloading and working fine for me. Using the updater, I got a crash after the download downloaded and before the install dialogue box came up. It then went on to install normally. We’ll see if I can reproduce using the laptop.

Will the be the “unlink option” in the right-click-menu for the final release?

I got this as well.

Lee, a lot of work there…! Kudos to you and team.

I tried the self-update, and it worked very well, with one exception. I had other windows beneath the Scrivener one, and when I hit Install for the update, the installer came up behind these, so was invisible and waiting for me to advance it. A simple focus-to-front ought to cure that.

Install was fast and smooth. I left both boxes checked, and read the update notes. Scrivener then came up after over 30 seconds, which it seems to do on first run after install consistently, recently. I am going to think this is the newest Norton Internet Security 2012 which emphasizes looking for actions over looking for signatures.

This may also be the reason it takes just under 5 seconds for Scrivener to open normally afterwards – this also seems lengthened substantially, though still in bounds.

Seems to work fine so far – it ought to :wink:


Stacey and Garpu - Which version were you updating from, 046?

Just a post to call attention to Lee’s amended initial post with instructions–if you are using 035, you must download and run the full 049 installer rather than using Check for Updates; otherwise, not all necessary files will be updated. Users on 045 (NaNoWriMo Trial) or 046 can use Check for Updates, though note that this will bump the expiration date for the NaNo Trial to Nov 7, so I recommend NaNo Trial users wait for the special NaNoWriMo update (v. 046) that will keep the Dec 7th expiration date (we’ll have that up shortly and I’ll post here when it’s available).

If anyone’s already used Check for Updates from 035 please download the fuller 049 installer and reinstall to make sure you’re fully up to date. Thanks!

Yep. I did a clean install from 035 to Nano, clean install from Nano to 046, then update from 049. For what it’s worth, pre-035 the updater worked fine. Edit: this is windows/wine, not linux native.

It downloaded and installed the update, so I think the crash might’ve been on Scrivener closing.

I did an uninstall then a clean install and mine says November 7th
WinXP Service Pack 3

Sadly, something bad happened on the road from 46 to 49. Things are acting pretty wonky at the moment to the point where I’m not able to use the program. When I open scrivener, it opens my previous project and a status bar in the upper right part of the page constantly runs over and over (in scrivenigs mode). Any document I click on in the binder exhibits this behavior. The scroll bar is also not functioning correctly, as it only scrolls down part way and I am unable to get to the bottom of the page. A third problem is the editor somehow split into a second document (oddly enough the second document window (now primary on the left) seems to function okay, but I can’t figure out any way to close the extra pane and get back to a single document. Only the malfunctioning window pane displays a info bar at the bottom.

My instinct is to do a full uninstall and then try a reinstall, but I figured I would post before doing so just in case this messed up condition provided any helpful information on what could have gone wrong to the developers.

I, too, have had problems similar to this – I updated from 35 to 49 by first uninstalling 35 & then installing 49. I am on Windows 7. I must confess the problems were so bad that for the moment I have uninstalled 49 & gone back to 35.

On 49, I could not navigate through my project in scrivenings mode. Once I got past the prologue, to Chapter 1, it threw a wobbly – it didn’t seem to want to allow me to move further down the document and the program got all sulky and unresponsive, with a green progress bar stuck at something like 60%. It still seemed a little laggy, when I went out of scrivenings mode and clicked on documents in the binder and tried moving through them.

I’m not sure it’s relevant, but I had a table at the start of Chapter 1, that I tried removing to see if it made any difference, but the behaviour seemed to continue. Also, when I closed the project in 35, I left it in split screen mode.

Has this new update been posted yet? I inadvertently upgraded from NaNo to 49, and now it expires Nov. 7. Waiting for news on this to redownload the (updated) NaNo Trial.

I uninstalled .35 and installed .049 and still have the Nov. 7 end date as well. Is there a fix for this, or am I out of luck in a week?

You can download the NaNoWriMo version,, which lasts through November. But there is an update to that supposed to be coming, so you may want to wait.

Can the 046 version still be downloaded from anywhere? I want to revert back from 049, but I didn’t manage to keep the 046 install file.


I downloaded beta 49, and I had beta 46. It said to install over the previous version. My files were not showing up. When I imported them they came in as numbers and not file names I had set. I have a zip backup, but not sure how to restore, I was getting organized for NaNoWriMo, and had planned to buy the windows version as soon as it came available, which was going to be the last day of Oct. I hear there is a NaNoWriMo version, but that sounds like it would complicate things even more-too bad I don’t have a Mac-what do you suggest? I am going through the files trying to replace them all manually by renaming. :frowning:

I closed it & reopened it and voila! The files are there-not sure what that was about. If it helps, the files the first time all came in under manuscript-and not in their original folders. Question:If I purchase the windows version on Oct 31, will I have to download anything else or will I just need to enter the registration key?