Beta 1.4 disasters

I’ve just done the upgrade to 1.4, and it:

(a) lost 10,000 words (and not all from one place, so working out what it has lost where is a nightmare)

(b) removed all my apostrophes from a random section

© lost all my manual carriage-returns in two random sections

No work has actually been lost, as I was copying and pasting everything to Word, but it does mean I’m going to have to abandon Scrivener until the final release. I found some of the lost words, but they were literally from mid-word in a section, and when I tried to paste and then import from Word, it again lost all the apostrophes. I also have no idea where the remaining missing words are - all the section beginnings and endings are there, so it’s from somewhere in the middle of one or more sections.

But when you did the upgrade, your original .scriv folder should be in the location you saved it to on your hard disk, in a different location from the Scrivener program files. What the upgrade has done is clear your “recent projects” menu, or whatever it’s called on Windows — I’m a Mac user. You need to find where on your hard disk you .scriv project folder is, find the .scrivx file in that and open it — so I understand.

There are coding issues with Word and apostrophes, and not just between Windows and Macs it seems; the missing words I can’t explain, you need a Windows guru, but if you locate and open your original .scriv project as above, I imagine you will find it all there.

HTH

Mark

The scriv folder is right where it should be: it’s not that a scriv file is missing, but rather that 10,000 words have vanished from that file.

I lost text, too, but in my case the lost text --in all cases I’ve found so far-- followed an MSWord Comment. So if I had the line:

we don’t have anything left besides [vodka] but if you bring some orange juice we…

where the square brackets indicate an MSWord Comment, the file after upgrading to Beta 1.4 reads

we don’t have anything left besides vodka

and the rest of the text is gone.

This afternoon I tried taking the same chunk of text, with MSWord Comment, and pasting it into a new file in Scrivener beta 1.4 without it ever having passed through 1.3, and I got

we don’t have anything left besides vodkaLater have her realize how staged this must
have been
but if you bring some orange juice we…

where the italics indicate the contents of the former MSWord Comment, in a smaller font, now inserted into the file.

The file within Scrivener was created by cutting from an RTF file, by the way, and pasting into Scrivener, rather than using the Import command.

So either 1) the text went missing before I upgraded to 1.4 and I just didn’t notice, or 2) this is an artifact of upgrading, but in any case, text including MSWord Comments, cut and pasted from an RTF into Scrivener beta 1.4, is now apparently fitting without arbitrary deletions into Scrivener. I do however have to go around mopping up the blood from the places where paragraphs have been amputated, which I’m doing by going back to the latest RTF file, displaying comments, and then finding those places in the Scrivener file, determining what’s lost and retrieving it. Except that FIND doesn’t seem to be working as expected in Scriv 1.4, but that’s a separate conversation.

Glad it’s not just me!

I haven’t knowingly used a Word ‘comment’, and the largest block of missing text literally started in mid-word. After a frustrating four hours of sorting out the random formatting Scrivener seems to use, I now have everything correctly formatted in Word.

I do still love the Scrivener concept, and will be using the release version once it’s out, but I shall be continuing in Word until then!

I’m surprised here, I lost absolutely nothing on upgrade. It’s all in a separate place, I don’t understand how it could have been touched. I’d be curious to see if the text was still there if you were to open the actual RTF file in Word.

We’ve felt some Word woes on the bug board recently. Where Word’s smart quote apostrophes disappeared upon import into 1.4, and things like that. But all RTFs that were saved with in Scrivener remained the same after the upgrade.

Out of curiosity were these files imported in a previous version of Scrivener, or were they copied into blank documents at that time?

The text started out in Word and was imported into Scrivener 1.3. It was definitely present for most of the time I was using 1.3, as I referred back to it frequently while writing the current sections, but it is possible that the text vanished a few days prior to the upgrade, though, if that’s what you’re suggesting?

I’ve just looked at the RTF files, and the largest chunk of text is indeed missing from the RTF file also.

Okay, now I’m terrified. Either there’s a bug in the wordcount function (oh please oh please oh please) or I’ve lost a massive amount of text.

I’ve been cutting from an RTF file, section by section–I already globally fixed the curly quotes because I read about that elsethread, and I am, section by section, turning the em-dashes into double-hyphens in Word before I cut.

I haven’t been noticing the wordcount, because it doesn’t display unless I’ve got the Scriv screen on max. Today I was curious to see how far I’d come, and it said I had 13K words. Ulp. Word tells me I’ve done over 100K words.

Here’s the sequence of events as best as I can give them to you:

  • I wrote many chapters in MSWord 2003 SP3 and saved them in a DOC file.
  • I converted the DOC file to RTF
  • I cut-and-pasted sections from the RTF file into Scrivener Beta 1.3 and did lots of little fixes to the scenes as I pasted them in (therefore it would be a real loss to have to start over on importing or cut-and-pasting files into Scrivener because I’d lose work)
  • I upgraded to Scrivener Beta 1.4
  • I lost text that appeared after MSWord Comments, as well as having problems with curly quotes and with paragraph indentation as discussed elsewhere (and elsewhere it says, I believe, the quotation marks problem is a problem only for MSWord 2007, which seems not to be the case)
  • I apparently lost massive, massive, massive amounts of text – or else the wordcount function is wrong.
  • I kept pasting in more sections and doing more work (more fool me)

Help? HELP?

ps to previous

Please note that the MSWord-Comment problem I posted about above cannot account for such a massive loss of text.

(And besides, I’ve fixed most of those.)

I tried exporting that portion of the manuscript that I’ve pasted into Scrivener so far, some 2 Mbytes of text, to see whether the material that seems (on the basis of Scrivener’s wordcount) to be lost is actually still there. I got the following error message:

Could Not Save the File day after “Jeans” – needs incident.rtf

Could save the file at C:/Documents and Settings/Ownder/Desktop/SCRIVENER PROJECTS/text exporting whole file from scrivener/10 Chapter/day after “Jeans” – needs incident.rtf

I hit OKAY and it gave me the same error message again, except with the “.rtf” stripped from each of the lines in the error message, so that each ends with “needs incident”

(NOTE:

day after “Jeans” – needs incident
is the title of one section of text in the Scrivener project I’m working on.)

I hit okay and went to try to find that “needs incident” line within my project. I did several find operations, because I haven’t yet figured out how Scrivener’s Find command works and I confess that for the first time, I’m getting frustrated. FIND ought to FIND, darn it. Would love to talk to someone about my find problems, which may very well be the result of the Find command working but just not working as I expect – but lets treat one problem at a time…

So somewhere in the flurry of me doing a global search, flipping in the left hand side of the screen from search results – listing one section – to the Binder view for the whole project, and back again, and doing another find, and doing some local searches with ctrl-F, Scrivener crashed.

So let’s see –

I had assumed Export would result in one big long concatenated RTF file, but I got a zillion little RTFs, one for each separate section of text I’ve got in my binder. Maybe I didn’t set up my export settings properly, but it pretty much only asked me for a directory and seemed to indicate it was good to go.

The total of the sizes of the number of little RTF files I got still doesn’t add up to anything like 2000K. Adding the numbers up quickly and roughly in my head it looks like they add up to about 325K.

Weird, weider, weirdest.

ps to previous (sorry if this is getting tedious! Well, it’s pretty tedious at this end, anyway)

I didn’t explicitly say that my Export attempts were attempts to Export to RTFs

Also, I should probably have said that when I look on the left-hand side of the screen at what’s in the Binder, I don’t seem to be missing any sections.

Mef, if you’re experiencing the same bug as me, then all the sections will be there in the binder, but there will be text missing from within those sections.

I’m always ultra-cautious about Beta versions of anything, so at the end of each writing session I copied-and-pasted the new text from Scrivener into a Word file. I thus have all my text, but with a lot of messy formatting that took several hours to correct, so I won’t be using Scrivener again until the release version has been out for a few weeks.

Thanks for your reply. Just noticed that mightygitis’s message said

Out of curiosity

Er, does that mean that discussions here aren’t officially to receive staff attention? Should I move this over to the Bugs forum?

Okay – I’m an idiot. I was getting the word count for that portion of the project that was selected. All I had to do was to compile the sections into the whole manuscript and then the wordcount was fine. I do not in fact have some terrible loss of a massive number of words.

Bushing furiously here.

However, the truncates-file-at-point-of-first-MSWord-Comment behavior was no small thing; but I’m not going to pursue it because that seems to be a problem in going from Beta version 1.3 to 1.4, which is something we’ve all either already done or will never do.

Now…to see whether Export will work this time…

Phew.

Glad you’ve found your missing words.

Dear Mef,

First, DEEP DEEP BREATH PLEASE.

Second, EXPORT is for exporting the pieces one at a time. COMPILE is for stringing them all together in one giant file.

Finally, any genuine bugs do need to be reported in the bug forum. For example the thing with the Word “comments” should be detailed in a single post on that board. That is where Lee goes to see bugs. I am a completely unofficial voice here on the forums trying to help the ONE official voice from being completely overwhelmed.