[Beta 1.4] Scrivener Link Bug

Expected behaviour

  1. Right click in editor window
  2. Select scrivener links
  3. Select document you wish to link to.
  4. Add as many links as necessary.


working scriv links by StaceyUK, on Flickr

Despite following the same scriv link procedure for all files I encounter an error on this one. Even reapplied the links, but as soon as re click on this document this behaviour occurs. All scriv links have been created using beta 1.4. Tried closing and reopening the project but error still persists.


broken scriv links by StaceyUK, on Flickr

Not sure how to recreate it as it only seems to be affecting this particular document so far.

ETA:

Another file is displaying the exact same issue as the second screenshot I posted. Will redo links and see what happens. I have an inkling what might be causing the issue. Will get back to you if I have more.

ETA 2:

The links appear to break when I use the tab key to indent Q&A and Misc. I’ve redone the links without using tab key to indent and the links now seem to be staying in place.

I have now managed to reproduce it in my test project

Steps to reproduce

Scenario 1

  1. Use the right click menu to create a scrivener link to another document
  2. Use tab key to apply indent to link.
  3. Close Scrivener
  4. Re-open project

Scenario 2

  1. Use tab key to apply indent to paragraph
  2. Use the right click menu to create a scrivener link to another document
  3. Close Scrivener
  4. Re-open project