(beta 10) Project and document bookmarks

I added some external bookmarks in inspector, but forgot to change to “document bookmarks” before.
So I opened the bookmark floating pannel and tried to drag the bookmarks one by one to the inspector (in document
bookmarks mode, empty). The arrow change to a “+” arrow, but when I release the mouse nothing happens (no bookmark is copied or moved)

I also tried to create an “internal bookmark” (to another document in the projet) and this one can be copied by drag & drop.

Yep, this one has been on the docket for quite a while. It’s actually the first bug I check on with each new beta release.

[LH4210] B30 Regression on dragging / rearranging external bookmarks

Semi-related, the dedicated Project Bookmarks control on the Projects menu is in need of attention as well.

  1. It doesn’t stay on top, so we can’t drag items into it.
  2. It doesn’t distinguish between a click (to open the doc) and a long mousekey hold with intent to drag.
  3. Bookmarks of type x-scrivener-item require a double click, whereas other bookmarks respond to a single click, and prematurely, per item 2.

Rgds - Jerome