Beta 13: Creating New Project Crashes Program

I was having trouble with a project (I wrote about it in this post:

Someone suggested creating a new project and importing it so I tried it.

However, creating a new project seems to crash Scrivener. Once I create the new project and the program crashes, I have to navigate to the file location and open the new project from there. If I try to create another new project the same thing happens.

I’m operating Windows 10 and the 64 bit version of beta 13.

I just had that happen here. Created the project. No issues. Then crashed.

However, I am able to reopen Scrivener afterwards, from the taskbar icon, and it opens whatever I had open.

The crash happens with the Novel Template, and only under certain conditions. Still trying to find those conditions.

Possibly a probabilistic glitch. Those are really hard to run down. But I just had Scriv crash twice in a row from this. And then not crash for eight consecutive new projects.

I’ve been using the novel templates and a custom template of mine. It seems to crash every time .I’ll try some other templates just to see what happens. Also I think I accidentally reported one of your comments and I don’t know how to undo it.

On that last, I think “Tell the moderator” is the appropriate course.

I couldn’t get it to crash on creating new from a blank template.
It crashed twice on the standard novel template, and hasn’t since those two.
Scratching head as to what the conditions are to reproduce it.
Hmm. Just did it a 3rd time. More investigation.


HUGE project. ~154k words. 100 scenes, 1.5k words each (or so). I have Custom metadata in the outliner (which I assume is chewing up memory like mad) of 3 text fields and 2 date fields. Most is not populated.

WAIT for it to load. Scrivener will use all available memory in loading, settle to 13 GB for a while, and then to 10 GB for the 1.1 million characters. Scrivener normally does not use that much. 2 GB of that is the custom metadata in the outliner (it’s inefficent in some way, I think).

Select the Manuscript folder.
Do NOT select a document, do NOT click in the editor.
File -> New Project -> Fiction -> Novel.

Give the thing a name, click create. You’ll get the note about Project Notes, and Scrivener will crash.

Also, exiting that huge project, with one of the created projects open, caused Scrivener to crash.

NEXT. Shrank the metadata showing in the outliner, so only 8 GB are used. Also crashed on New Project -> Fiction -> Novel.

Opened a SMALL project. One o f the newly-created ones during the above process (not sure I trust them, but…).

Opened an OLD small project.
Couldn’t crash it this way.

Turned OFF “Reopen projects that were open on quit”.
Started Scrivener normally, which loads the project creation window.
Tried to create Fiction->Novel

Tried to load one that didn’t break. Crashed on load.

Reloaded an old one (from Beta 2910). Loaded fine.
Create a new one. Created fine, opened the new file automatically.
Closed the old file. Crashed.

With one of my projects, creating a new project (when Manuscript is selected) usually crashes – IF I load the custom metadata into the outliner. I have Beta 12 installed in a separate directory, checked that, and it does not have the same problem.

I loaded the big problem doc in B12 (the first one mentioned in this post). It only uses 4 GB of memory instead of 8 or 9 (with the metadata loaded as well). Also, no crash when I create a new project.

I zipped up the problem file and put it here: It’s nothing at all critical or even copyrightable; it’s Lorem ipsum text with crazy custom metadata (which is mostly not filled, but some dozens are). Beta 12 doesn’t even burp. Beta 13 crashes.

I think it’s a memory issue. It’s worse in Scrivenings mode, but it will happen in Corkboard mode, too.

Devs, hope that helps.

I have 16 minidump files on this; just discovered them while cleaning out the Beta 13 install.

If the devs what to look at them, they’re at

Figured I’d hunt down some projects that crashed on creation. These are openable with Beta 14 (if I trash the user.lock file), but would crash Beta 13 on opening.

4 of them are zipped at

There’s still a user.lock file, because Scrivener crashed right after these were created, and didn’t undo the lock file. When trying to open them with Beta 13, Scrivener would crash.

Not sure the issue persists in 14, though. Posting these in case the devs want to look at them.

I haven’t played with this a ton, but I think I’m getting something similar, if not the same thing. Basically, I just installed beta 14, and when I opened it for the first time, it asked me to name/create the tutorial file, which I did (I do this new for each beta I try, which isn’t a lot of them). Scrivener instantly crashed as soon as I named the document, and when I tried to open it again immediately, it locked up/stopped responding, though I WAS able to close it with the X. Left it alone for a few minutes and was able to open it without problem a few minutes later, and though it didn’t immediately open the tutorial project, it was in the list of available/recent files and I was able to open it from there, without issues.

I’m still having issues with this,

I created a new project and saved it. Scrivener immediately crashed This time it was with one of my imported templates. I saved it in one of my writing folders. The project refuses to open. None of the ways I normally can get it to open work. It’s blank other than the template files. Other projects saved to that same writing folder open fine.

I created the exact same new project with the exact same imported template and this time I saved it to the desktop. Scrivener still crashed upon creating the project, but it will open when I go to the desktop and open it directly from there.

It seems like Scrivener is having issues with the custom template. Does it happen with all templates, or only the custom one. If it is only the custom one, please upload it in this forum, or email it to tiho at

It’s not happening with all templates but it’s not just custom templates either. I’ve had trouble with the novel template included with Scrivener too.

With Beta 13, the built-in Novel Template would cause crash on creation, but not all the time (see prior post; 2 crashes on creation, then no crashes for 8 attempts).

With Beta 14, I haven’t been able to duplicate this yet.