Beta 13 Text to Speech TTS output channel not selectable

I’m on a laptop running Windows 10 Home that has built in speakers. When I plug headphones in or connect via bluetooth, the sound from the TTS still comes out of the speakers.

I have tried:

1 - Restarting the application after the switch
2 - Plugging in before starting the application
3 - setting the output channel for the application through the Windows settings (right click on the speaker icon, select “Open Sound Settings”, scroll to “Other sound options” and click on “App volume and device preferences”.
4 - #3, restart computer, open scrivner 3 beta
5 - changing the “Narrator” OS setting to use the headphone output channel (with and without computer restart)
6 - disabling the built in speaker and then #1 - 5 again

Something I noticed is that this also occurs with my normal TTS reader, Balabolka []. They have added an app setting to select the output channel, which solved this issue for them. It is not an issue with other TTS software I use, so I’m thinking it has to do with how the TTS engines get called???

Also worth noting, I have to restart the computer right after installing the beta to be able to get the TTS working at all.

Apologies for forgetting this:

Scrivener: Beta (467076) 64-bit - 11 Feb 2019

OS Name Microsoft Windows 10 Home
Version 10.0.17134 Build 17134
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer HP
System Model HP Spectre x360 Convertible 15-ch0xx
System Type x64-based PC
Processor Intel® Core™ i7-8550U CPU @ 1.80GHz, 1992 Mhz, 4 Core(s), 8 Logical Processor(s)

[Sound Device]

Item Value
Name USB Audio Device
Manufacturer (Generic USB Audio)
Status OK
PNP Device ID USB\VID_046D&PID_0A29&MI_00\6&3833B8F3&0&0000
Driver c:\windows\system32\drivers\usbaudio.sys (10.0.17134.1, 148.00 KB (151,552 bytes), 4/11/2018 3:33 PM)

Name Realtek High Definition Audio(SST)
Manufacturer Realtek
Status OK
PNP Device ID INTELAUDIO\FUNC_01&VEN_10EC&DEV_0295&SUBSYS_103C83BA&REV_1000\4&2C7C774F&1&0001
Driver c:\windows\system32\drivers\rtkvhd64.sys (, 5.86 MB (6,143,944 bytes), 10/5/2018 10:31 PM)

Name NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Manufacturer NVIDIA
Status OK
Driver c:\windows\system32\drivers\nvvad64v.sys (, 49.44 KB (50,624 bytes), 6/9/2018 5:42 PM)

Name Intel® Display Audio
Manufacturer Intel® Corporation
Status OK
PNP Device ID INTELAUDIO\FUNC_01&VEN_8086&DEV_280B&SUBSYS_80860101&REV_1000\4&2C7C774F&1&0201
Driver c:\windows\system32\drivers\intcdaud.sys (, 800.95 KB (820,168 bytes), 12/7/2017 11:15 PM)


Item Value
Name Intel® UHD Graphics 620
PNP Device ID PCI\VEN_8086&DEV_5917&SUBSYS_83BA103C&REV_07\3&11583659&1&10
Adapter Type Intel® UHD Graphics Family, Intel Corporation compatible
Adapter Description Intel® UHD Graphics 620
Adapter RAM 1.00 GB (1,073,741,824 bytes)
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\ki126951.inf_amd64_94804e3918169543\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki126951.inf_amd64_94804e3918169543\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki126951.inf_amd64_94804e3918169543\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki126951.inf_amd64_94804e3918169543\igd12umd64.dll
Driver Version
INF File oem0.inf (iKBLD_w10_DS section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 3840 x 2160 x 59 hertz
Bits/Pixel 32
Memory Address 0xDB000000-0xDBFFFFFF
Memory Address 0x70000000-0x7FFFFFFF
I/O Port 0x0000F000-0x0000F03F
IRQ Channel IRQ 4294967285
Driver c:\windows\system32\driverstore\filerepository\ki126951.inf_amd64_94804e3918169543\igdkmd64.sys (, 12.22 MB (12,809,648 bytes), 3/7/2018 3:48 AM)

Name NVIDIA GeForce MX150
PNP Device ID PCI\VEN_10DE&DEV_1D10&SUBSYS_83BA103C&REV_A1\4&175EE3D1&0&00E0
Adapter Type GeForce MX150, NVIDIA compatible
Adapter Description NVIDIA GeForce MX150
Adapter RAM (2,147,483,648) bytes
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll
Driver Version
INF File oem5.inf (Section088 section)
Color Planes Not Available
Color Table Entries Not Available
Resolution Not Available
Bits/Pixel Not Available
Memory Address 0xDC000000-0xDD0FFFFF
Memory Address 0xB0000000-0xC1FFFFFF
Memory Address 0xC0000000-0xC1FFFFFF
IRQ Channel IRQ 4294967284
Driver c:\windows\system32\driverstore\filerepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvlddmkm.sys (, 16.40 MB (17,200,384 bytes), 7/4/2018 2:39 AM)

Issue continues in Beta 14

I am running Windows 10 1809 Build 17773 With beta 14
And when I plug in my headphones to the headphones jack it works fine.

Just a data point. Key difference might be that the same driver handles both on my HP… Where if you are using a USB headphone that would require changing drivers.

Continues into beta 16

Yes, I am trying to use USB headset. I have not tested b16 with the headphone jack.

I do have to restart the computer after installation to get the voice to start working, and it is only coming out of my laptop’s speakers.

I have the headset set as the default sound output device, and I’ve set it as the specific sound output device for Scrivener through the Windows settings.

I suspect that the issue is specifically related to how windows handles TTS voices because I only have this issue with TTS voices. Other software I use that focuses on TTS [specifically Balabolka ] overcame this issue by providing a sound-output option in the software.