Beta 2.9.13 for Windows Scrivener Format scrformat files

Beta 2.9.13 Installed on fresh windows 10 all updates. Installs ok. Appears to work.
Copied a couple of projects over from my mac on High Sierra where I use Scrivener 3.1.1 (build 9852).
Copied scrformat files over to use with my novel and another for my scripts. I made my own. Those file types are used under compile, scrivener formats. i used the export function on the mac side, then copied them over to Windows.
When I go to import my customized files, the files are NOT even view-able (cannot see to select).
A bug or am I missing something?
Thanks
Chad

Hi Chad, the “Import Formats…” menu action allows you to select the *.scrformat files you have exported from Mac. They do appear in my tests. Could it be that your Mac exported files do not have the “.scrformat” file extension.

You can also drop your *.scrformat files inside the “Settings\Compile Formats” subfolder of your project and they should appear as compile formats for your current project too. Have in mind that the Windows compiler has some functionality ready, but some is also under further development.

If nothing helps, please upload few *.scrformat files so that I can reproduce your problem.

Thank you for responding.

After reading your advice, I checked and the files I exported from scrivener on my mac do have the file extension .scrformat, but do not appear when i click the ‘import .scrformat’ function under compile. I took two screenshots; the first shows the files are missing from the import process in scrivener, and the second shows the files in the folder on my windows machine. I attached those two screenshot images to this reply.

I took your advice and copied the files into the project folder; ‘settings’, ‘project folder’, and I still cannot see the files.
I tried attaching these files to this post but the post won’t accept it.



here are the files.
I got them to attach to this post.
Let me know if you have any luck.
The only thing I can think of is I uploaded the files to my google drive and when i downloaded them they were zipped up automatically by google and then i unzipped them when I downloaded them to my windows laptop. I will do a test and email them to myself and see if that changes anything.
Chad
My Modern Copy Novel.scrformat.xml (47.6 KB)
US Stage Play MINE.scrformat.xml (45.6 KB)

Hi
I figured out the problem and I do apologize for taking up your time.
It seems when google zipped the files, (it does that when you download multiple files at once from google drive) it added the .xml file extension behind the scrformat extension but the xml extension was not showing in the file name. I saw it when I right clicked the file and looked at the details.
So lesson learned: do not allow Google to zip the files up when you download them from google drive. I imagine google scans the files and adds an XML extension for some reason.

When I emailed the scrformat files to myself, Scrivener immediately saw them and exported them in under ‘Compile’.

Again, sorry about the posts.
Chad

Glad you have found and fixed the problem with the file extensions, Chad.

Google Drive --There’s a setting called “Convert uploads into Google Doc format,” and it might be checked? Not sure about that. I’ve never had it muck with my extensions before.

Windows generally doesn’t show extensions (you can force it to: File Explorer → View → File Name Extensions).