[Beta 22] Blue Screens (not the kind you first think, but significant (and blue) nontheless)

I’ve complained before, no notice taken, but now I see this once more with a further clue.

  • I opened the Mac Scrivener 2->3 upgrade guide recently mentioned for understanding the new Compile, by @Kewms.

  • I was presented with what I’ve reported before on some pages of the very current, new and upgraded templates, in particular the Front Matter text page of the Short Story template.

  • This is black type, against a dark background for the offending page/s

  • it occurs when a dark-tending Theme is used. Because I’ve got the Ocean theme up already so as to not lose such text entirely, the darkened screen is Blue, as you can see in the laboriously provided screenshot below.

  • the Clue is this: The problem occurs continuously through the Upgrade Guide.scriv. The Upgrade Guide was produced for, and doubtless on, Mac Scriv. Ergo, it’s something not working between Mac Scriv and Windows Scriv that’s causing this makes-text-invisible problem.

  • I did indeed allow? the auto-upgrade of Scrivener file type proposed as I opened this Guide.

  • you might want to see that this could be logged, as it is a true frustration just using templates. Thankyou.

  • If you doubt, just try the maneuver or the mentioned Short Story template page, on a truly Dark template…

Now for the screen, suitable Dropbox incantations to be muttered:

Thank you for reporting.

Of note is that the theme settings are not part of the project itself. A project created on a Mac in Dark Mode should transition to a PC (or another Mac) in Light Mode – or vice versa – with absolutely no need for user adjustments.

On the Mac, Dark Mode has two possible approaches to the problem of black text on a black background. One is to reverse the colors, giving light text on a black background. The other is to keep the Editor pane light and the rest of the interface dark. So that’s the expected behavior, and if the Windows version doesn’t do that, it’s a bug.

Katherine

Thanks, Katherine.

And I think you’ve got it…

To fix the black text on dark background simply remove the text color. This will produce proper colors in dark and light themes. This something to be fixed in the following releases.

Thanks, Tiho, confirming workaround, and plan.