beta 24 - Compile Styles Prefix/Suffix no longer working (MMD)

In previous betas, the “Styles” section of a compile’s project format in Multimarkdown (have not tested other compile formats) would work as expected. I am now experiencing a problem wherein adding a prefix/suffix no longer works upon compiling. However, selecting “Delete text of this style” does work as expected.

If you overwrite a project style with a compile style by name, make sure the project and compile styles match by type too. i.e. both are par, char or par/char styles. If they do not match by style and type, they might not get applied as expected(this was fixed in the last build).
If this does not help, please upload a small demo project.

Thanks for responding. I have been using style overrides. I’ve attached a demo project that shows the problem I’m having—compile it to the MMD → HTML format.
project styles replace bug (33.7 KB)

Thank You, Corgi! I managed to reproduce the problem. The latest ePub improvements with styles have caused issues compiling the styles to the other formats properly. This has been fixed and will be available in the next update.

Wonderful, thank you!

It seems like this bug has never been sorted out. I just cannot make Prefix/Suffix to compile with Styles in any format. They just won’t show up in the compiled document.
For me, “Delete text of this style” option does not work either. All settings on the Styles section in the ‘Edit format’ menu on ‘Compile’ are IGNORED.
Any guess what am I doing wrong? Or is it still a bug then? (Have just installed beta 41 – don’t know if it is an old error coming back or this problem’s been never addressed.)