Beta 35 will not start...

I am trying to run Scrivener Beta 35 on Windows XP service pack 1 in a VirtualBox window with Ubuntu 10.10 as the host machine.

The previous Beta # 29 had been starting and working without a problem other than those reported.

(1) - When I tried to install Beta 35 I forgot to remove Beta 29 on the first installation and got an error message when I tried to run Beta 35. Realizing the mistake I un-installed Scrivener, shutdown and restarted XP and then ran the Scrivener installation program. When I tried to start Scrivener I got this error message:


C:\Program Files Scrivener\Scrivener.exe
This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix the problem.

(2) - So assuming that the Windows un-install program had missed something I un-installed Scrivener, went through all directories and deleted any Scrivener files and directories except the ones I made in My Documents to hold the .scriv folders and files. I then did a system wide file/folder search for Scrivener–nothing was found. Shutdown XP and then VirtualBox and restarted VirtualBox and XP.

I then installed Beta 35. No problems with the installation.

I got the same error message as above.

(3) - I went through he complete un-install, looked for and striped Scrivener files and directories, shutdown and restart everything and reinstall procedure as above again.

I got the same error message.

Any suggestions as to what to try next? Could this be a possible problem in the registry?

Keith

I did another complete uninstall and then a manual removal of all Scrivener files and folders still remaining after the uninstall–THEN I went though the registry and removed all Scrivener references except those to My Documents where I stored the project files.

Then I did a close and restart of both Scrivener and VirtualBox and reinstalled Scrivener.

No change, I still get the error message and it will not start.

At this point I think it is a problem with Scrivener and XP.

Keith

Hi Keith, I had the same problem, forgot to delete Beta 029 before installing the new version. I did the same things you did, deleted every Scrivener program file I could find and so on. Oh, I work with Windows XP as well, Service pack 3 though, not sure whether that makes any difference.

I additionally checked my “System Control” Software list (not sure whether it’s called like this in English). The older version was still on the list, only an empty shell, but I deleted those remains as well.

The new Beta runs without any problems now. Maybe this helps? Hope so.

Greetings,
gg

hi gg

Thanks for the info.

I just installed Service pack 2 and did the complete removal and reinstall again and I got the same error message. So I don’t think the problem is related to which service pack you have installed. If I had SP 3, I would try installing it. Maybe I should search for and download it.

I would like to check “System Control” Software also. But I do not know where it is. Is it part of the registry?

Will be gone for 3 or 4 hours so any reply to a new message from you may be delayed.

Keith

Hi Keith, I may have forgotten to mention the most important detail! Sorry.

Have you seen the XP post on the Windows support board?

XP PROBLEMS RUNNING SCRIVENER (READ THIS IMPORTANT NOTICE)

If I recall it correctly, Beta 029 would run on my computer without needing to do this download, but I had to do it for Beta 035 to get it running. So maybe you need to too? You do get exactly the error message they mention, so it could be worth a try.

Good luck!
gg

p.s. The Software button in System Control. Oh, this is probably very simple but I find it difficult to describe because I don’t know what your English version of Windows looks like, what words they use. This is basic stuff and I might only confuse you because I don’t use the right words.

It’s where you usually go to uninstall programs. When you go into the Windows main menu you get to things like All Programs and Search and there also is your System Control (though I’m not sure it’s called that way).

When you open the System Control window you get to Software, among other things, and if you open the Software window you can see everything you have installed and could unistall it there. There should only be one version of Scrivener on the list.

Sorry I can’t say it in less words. I don’t even think this really is your problem anymore.

My money is on

!!

gg

GeeGee, I think you are really helping here, and I appreciate the difficulties in naming things – I ran for many years on a German version of Windows…

The English version of what you trying to name as ‘System Control’ is ‘Control Panel’. I think the name for the Control Panel item that lets you uninstall changes according to Windows Version; in XP I believe it’s called Add or Remove Programs. This should be enough information for Keith to be sure about your advice.

From the symptoms, it sounds very much that you have the right answer in the posting you alerted to from Lee, as it sounds like he’s talking exactly about Keith’s experience: XP PROBLEMS RUNNING SCRIVENER (READ THIS IMPORTANT NOTICE)

The key will be to download and install this component Microsoft has left out from within the virtual machine where Keith has it missing. Keith’s problem is configuration within that virtual machine he is for some reason running, not in his base computer.

Regards,
Clive

Thanks gg and Clive.

I give up. I will install Service pack 3 (which I am downloading now) and will download and install the missing MS parts.

I am not positive that the missing parts are the problem since Beta 29 worked fine but I am really tired of messing around with the XP part of the problems so I am going to install it just to make sure. I would much rather ignore Windows and just play with Scrivener…

BTW the “some reason” that your mentioned is that somehow running XP inside a steel cage as an application on a different OS where nothing it does can touch my host OS, the data stored there or my hardware, just seems like the safe thing to do…

This time I am going to build a Virtual Machine and clone it before I mess it up. That way it only takes 5 min to have a complete XP system running again after I break it… which I always seem to do. Then every time I install the latest version of Scrivener I can do it in a brand new clean machine without spending more than 5 min. doing it.

Thanks again for your advice.

Keith

Installing a late version of XP pro with SP3 already integrated along with the Visual C++ stuff that Microsoft left out solved all the problems.

I’ve only started Scrivener and looked at a little of the layout but what I saw sure looks nice.

Thanks all

Keith

Great, Keith; glad to hear you’re up and running, and then the experience is here for anyone else.

I’m really enjoying 035, and now you will be.

Best, and to GeeGee who came up with the answer!

Clive

Keith, that’s great!!

It’s so frustrating when you spend all that time trying to fix something and nothing works. Glad you got through it.

Hi Clive, nice to meet you and thanks for helping to zoom in on the problem!

gg