Bibliography doesn't show up when directly exporting to PDF

I’ve prepared a minimal working example consisting out of a scrivener file and my compile preset which I use in Compile > LaTeX Options > LaTeX document class > Custom .

I want to output a PDF directly via “Compile For: MultiMarkdown → PDF”. If I do this my bibliography doesn’t show up in the document and all citations stay unresolved.

The thing is, everything works fine when choosing “Compile For: MultiMarkdown → LaTeX (.tex)” and building the PDF via the CLI or in Sublime Text via LaTeX Plus.

I have no idea why this isn’t working. Please help me out.


For the purpose of this being a minimal example I included my biliography in the Header section of the preset like this:

\listfiles \usepackage{filecontents} \begin{filecontents}{literature.bib} @article{Anderson:1999, Author = {Anderson, Kirsten L.}, Journal = {Journal of Sport and Social Issues}, Pages = {55-79}, Title = {Snowboarding: The Construction of Gender in an Emerging Sport}, Type = {Journal}, Volume = {23}, Year = {1999}} @online{McGrane:2014, Author = {McGrane, Sally}, Day = {17}, Month = {February}, Publisher = {The New Yorker}, Title = {To the Magic Mountain!}, Url = {}, Urldate = {2014-03-23}, Urlday = {23}, Urlmonth = {March}, Urlyear = {2014}, Year = {2014}} @book{Mann:1924, Author = {Mann, Thomas}, Edition = {Gro{\ss}e kommentierte Frankfurter Ausgabe}, Volumes = {5.1}, Editor = {Neumann, Michael}, Publisher = {S. Fischer GmbH}, Rating = {5}, Title = {Der Zauberberg}, Location = {Frankfurt am Main}, Note = {PDF Version}, Origdate = {1924}, Pagetotal = {1362}, Year = {2010}} \end{filecontents} \addbibresource{literature.bib}

Normally I’d like to call my file via: \addbibresource{/Users/memyselfi/Desktop/citations.bib}

… anyway, both don’t work. Any tips are appreciated.

It sounds like you’ve hit the limit of the straightforward MMD to PDF compile. That compile option doesn’t go round the compile circle enough times to sort out the bibliography and citations. As the Scrivener manual explains:

I don’t think there is any option other than running in manually enough times to pick up all the bibliographical information.

Mh. That blows. Maybe there’s a way to change the compile command(s)/script Scrivener uses. Somewhere on my Mac must be a file that I can tweak… and I will hunt that file down. :smiling_imp:

Yes, it is possible to “subvert” the MMD post-processing scripts to do whatever you want (even not use MMD at all since Scrivener merely triggers shell scripts with STDIN/STDOUT, with the compile right settings). Here are the details (written for someone interested in using Pandoc instead):

Thanks for the link. I’ll check out that workflow.