Big Spacing after Compiling

Hi There - I’ve been writing my book in Scrivener since the beginning, and the spacing seems normal in the manuscript. However, when I compile, the spacing in some areas of the manuscript becomes bigger. I have no idea why this is happening and it really doesn’t look good (while also being painfully noticeable). I would appreciate any help I can get. Thanks!
It is evident in “football team for the next season.”

https://britton44.blogspot.com/2018/05/blog-post.html

This looks like a classic case of narrow column, full justification, and either a) automatic hyphenation is OFF or b) the first word on the next line can’t be hyphenated. Happens all the time in lots of output–even professionally typeset output, though they can adjust the line manually to not look quite so bad. To get this looking better, you’ll need to edit your compile format.

Your choices are:

  1. adjust your page size and margins so the column isn’t quite so narrow (but it will happen occasionally despite all, and if you’re doing an e-book you don’t have control over those.) You can change this under “Page Settings” in your compile format.
  2. turn on automatic hyphenation if it’s not on already. You can change this under “Text Layout” in your compile format. If hyphenation was already on, this won’t help.
  3. turn off full justification in your section layouts and go with a ragged right edge. To change this in your compile formats, adjust the alignment of each of your section layouts that includes text.
  4. leave it as is, knowing that occasional glitches of this kind are part of having the nicely even right edge.

Please do be aware that even with hyphenation on and a wider column, you will still get occasional artefacts like this if you use full justification alignment. In order to get that right edge to line up, the layout routines have to add horizontal blank space to the line–occasionally so much that it’s noticeable.

Hope this helps.

Thanks for your help, it explains it all perfectly. I appreciate it!

You’re welcome!