Binder always visble on opening

Whenever I close Scrivener, the binder is not visible. But when I start the program again, it is visible. Is this a feature or a bug? I’d prefer it if the program remembered the state it was in when I closed it.

It should indeed be working the way you describe wanting it to work. I’ve never had it happen that the binder comes back after leaving it closed—unless I deliberately reset the layout settings for the project naturally. Here’s what I tried:

  1. Create a new blank project.
  2. Close the binder.
  3. Close the project.
  4. Open the project.

I also tried changing my settings so that the software works more like how it sounds like you use it, where projects are reopened automatically if you leave them open upon quit. So instead of closing the project and then opening it again in one session, I fully quit, and then launched the software rather than opening a project specifically, letting it reopen it for me.

Should I be trying another procedure?

So further investigation shows this is only happening with one of my projects.

  • I open the project (by opening a desktop shortcut to the .scrix file). The binder is open.
  • I close the binder.
  • I fully shut down the program
  • I open the project again. The binder is open.

Shall I send you the .scrivx file?

That data wouldn’t be in the .scrivx file, but is rather a cross-platform layout setting, found in the Settings/ui-common.xml file. Here is what it should look like, in a project hiding the binder:

<UIStates>
    <Binder Show="No">
        <ShowCollections>No</ShowCollections>
        ...

My guess though is that there is little for us to learn from the result. If it is consistently printing Binder Show="Yes" despite the actual circumstances, then the reason for that won’t be found in the file most likely.

What I’d do is save your settings to a Layout, close the project, trash this and the ui.ini file, and then reload. Test that the binder state is saved properly, and then apply the Layout to restore your settings.

If the problem returns after applying the Layout, then I bet we could learn something from that layout file (you can export it via the Window ▸ Layouts ▸ Manage Layouts... command, with the ∙∙∙ button along the bottom.

Settings/ui-common.xml has Binder Show=“No” , and still the binder opens.

I saved two layouts, one with binder open, one with it closed.
The little picture clearly shows the difference between the two layouts, but they both load the same layout – with the binder open.
I’ll send them.
!! I seem to have discovered another bug while doing this, that I’ll report in another thread. But I need to get back to work!

Perhaps it’s relevant to mention that the binder window is set to display a collection when this happens.

Thank you for mentioning this point.

@AmberV, I can confirm this behavior. It was easy to replicate with the Tutorial project, by enabling/disabling Collections.

When Collections ARE NOT displayed, prior binder status (open/closed) is retained upon next open of the project. Scrivener works as intended.

When Collections ARE displayed, prior binder status is not retained–upon next open of the project, the binder is ALWAYS open. Scrivener does not work as intended.

Best,
Jim

1 Like

Thanks! That is indeed the primary, if only, trigger. I’ve never noticed that because taken to mainly loading collections into the main editor directly, as I find the menu easier to work with than that tiny little frame above the binder. We really need to fix that so you can expand it as tall as you want (i.e. all the way to floor, why not).

1 Like